locked
startsubprocess: Limit on 'Max worker threads' reached. RRS feed

  • Question

  •  

    My logs were being filled with the following messages -

    Process ID 98:112 owns resources that are blocking processes on Scheduler 4.

     

    I posted my question here and was referred to this KB article

    http://support.microsoft.com/kb/319892

     

    I was able to supress the above message by setting the trace flag as stated in the article.

    Now I'm getting only the following error message -

     

    startsubprocess: Limit on 'Max worker threads' reached.

     

    I tried increasing that number from 255 to 500, but the error messages increased.

    I read up on the whole Max Worker Threads but couldn't find a definite answer on what I should do in this situation.

     

    Any help would be greatly appreciated.

     

    Thanks

    Susan

     

    Thursday, April 10, 2008 9:15 PM

Answers

  • These error messages came back and I ended up calling MS for support.

     

     

    According to the above trouble-shooting, we find two kind errors as below. I assume that the backup error was caused by the ‘startsubprocess’ error. So we will be focus on the process error first.

    - BACKUP error

    -startsubprocess: Limit on 'Max worker threads' reached

     

    1.         Please verfiy the number of physical CPU on the server. I guess the server is hyperthreaded, the physical CPU number is 8.

    2.         If yes, we will try to edit ‘max degree of parallelism’ server option. Please run below script,

    sp_configure 'max degree of parallelism',8

    Reconfigure with override

     

     

    We did have hyperthreading on a 8 CPU machine, I ran the sp_configure statement and haven't seen the error message since.

     

    Thanks

    Susan

     

    Monday, May 12, 2008 4:42 PM

All replies

  •  

    Courtesy of the late Ken Henderson:

    http://blogs.msdn.com/khen1234/archive/2005/11/07/489778.aspx

     

     

    I suggest you read through this article before changing MWT.

     

     

    Friday, April 11, 2008 7:52 AM
  •  

    Very good article...

    I won't mess with the MWT...

     

    But I'm still getting the error messages and need to figure it out.

    I've been profilling the box and everything seems within range.

    Any ideas?

     

    Thanks in advance

     

    Friday, April 11, 2008 4:47 PM
  •  

    Shocker... But Ken Henderson was right!!

     

    There has to been an underlying reason why you run out of MWT's...

     

    Turns out I had two jobs that were running every two minutes and performing the same task.

    Once I shut one of those jobs, the error messages stopped.

     

    Thanks for everyone's help.

     

    Susan

     

    Friday, April 11, 2008 5:16 PM
  • These error messages came back and I ended up calling MS for support.

     

     

    According to the above trouble-shooting, we find two kind errors as below. I assume that the backup error was caused by the ‘startsubprocess’ error. So we will be focus on the process error first.

    - BACKUP error

    -startsubprocess: Limit on 'Max worker threads' reached

     

    1.         Please verfiy the number of physical CPU on the server. I guess the server is hyperthreaded, the physical CPU number is 8.

    2.         If yes, we will try to edit ‘max degree of parallelism’ server option. Please run below script,

    sp_configure 'max degree of parallelism',8

    Reconfigure with override

     

     

    We did have hyperthreading on a 8 CPU machine, I ran the sp_configure statement and haven't seen the error message since.

     

    Thanks

    Susan

     

    Monday, May 12, 2008 4:42 PM