none
USB HID device problem needs help RRS feed

  • Question

  • Dear All

    i am a quality control officer and dont have a hardware technical knowledge but i have two versions of interactive white boards,these boards is a touch boards connected to the computer through the USB port and appears in the device manager as HID compliant devices,the problem we are facing that the old version of these boards working properly with windows 7 and and windows 8 but the new version has the following two problems:

    1. problem with windows 7 :if the user connect the touch board to the computer after the machine starts up and windows loads there will not be any problem but when connect the touchboard to the computer then turn the computer on or restart it the board will not work correctly and will not send the correct events to windows untill unplug the usb cable then plug it again to the computer.
    2. problem with windows 8 : if the user connect the touch board to the computer after the machine starts up and windows loads there will not be any problem but when connect the touchboard to the computer then turn the computer on or restart it the board will not work totally untill unplug the usb cable then plug it again to the computer.

    i dont know what is may be the reason for this problem and i woul appreciate any help to only know what is the reason and also it will be very helpfull if anyone can send me some materials about how windows detects these devices.

    thanks & regards

    Osama Bader

    Friday, March 1, 2013 1:23 PM