none
Cannot view Design view

    Question

  • Hi there.

    When I open a web file in Visual Studio, I can see the code but when I try to switch to design view, the program freezes and i cannot see the design view. Is this a common problem?

    Sunday, November 29, 2015 4:04 PM

Answers

  • I have done this, it hasn't made a difference. I already had the three options you listed, just when I click on Design, the pane does not respond. Would it be a problem with my PC?

    It could be some reason related your PC or VS2015 , Though before processed for next step I want to confirm few more things. 

    Have you tried to create some windows based application and see still facing design view options, If yes then first suggestion to try to repair your VS 2015. 

    And if still have issue then raise a ticket to Microsoft Support team for help.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 6:14 PM

All replies

  • Hi,

    Welcome on MSDN forum.

    When you say program freezes, did you not able to click on menu either?

    If possible could you please share the screen shot of your page.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 4:14 PM
  • My apologies, the whole program does not freeze, only the view of the file. I can close the file and reopen it, but I can't edit it until i do this. I cannot upload a screenshot. The view says design but it doesn't show me the design view.

    Sunday, November 29, 2015 4:27 PM
  • Thanks for confirmation.

    Please check below two points,

    1. Is your web file in saved in read-only mode, if yes then please uncheck the option and try again.
    2. Have you opened your application as administrator, please check and try again.

    I look forward to receiving your test results.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 4:35 PM
  • No, its not in read only mode, and I have tried both running as normal and running as an administrator.
    Sunday, November 29, 2015 4:40 PM
  • Ok, So now could you please check your code is written in proper format, without missing any close tag. Can you post the code what you able to see.

    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 4:43 PM
  • <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Main Page.aspx.cs" Inherits="A00207736_Assignment.Main_Page" %>
    
    <!DOCTYPE html>
    
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
        <div>
        
        </div>
        </form>
    </body>
    </html>
    
    That is all the code that is in the file. I have just created it; I haven't edited it yet.
    Sunday, November 29, 2015 4:47 PM
  • Use below and see the result,

    <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Main Page.aspx.cs" Inherits="A00207736_Assignment.Main_Page" %>
    
    <!DOCTYPE html>
    
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
        <div>
        <h1>Hello World!</h1>
        </div>
        </form>
    </body>
    </html>

    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 4:52 PM
  • Unfortunately, that hasn't worked either. The page runs fine in the browser, I just still can't switch it to design view.
    Sunday, November 29, 2015 5:02 PM
  • Unfortunately, that hasn't worked either. The page runs fine in the browser, I just still can't switch it to design view.

    Wow. That means your application is working fine.

    Now please check below settings are enabled,

    under Tools > Options > HTML Designer Enable HTML designer checkbox is enabled like below screen shot,


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 5:19 PM
  • Hmm, it seems I don't have an option for HTML Designer, but I do for Web Forms Designer, and the options are exactly the same as in your screenshot. Could it be this?
    Sunday, November 29, 2015 5:24 PM
  • Which version of VS are you using and what is your OS type ?

    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 5:26 PM
  • Visual Studio 2015, Windows 10
    Sunday, November 29, 2015 5:29 PM
  • Visual Studio 2015, Windows 10

    Try below option,

    1. Right click on an web file listed in Solution Explorer
    2. In dialog box that opens click on: Open With
    3. Click on: HTML (Web Forms) Editor, AND on the right pane click on Set it As Default

    Screen shot should be like below, and restart your VS.

    Create new project and after this action all files that you open have options: Design...Split...Source.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 5:56 PM
  • I have done this, it hasn't made a difference. I already had the three options you listed, just when I click on Design, the pane does not respond. Would it be a problem with my PC?
    Sunday, November 29, 2015 6:05 PM
  • I have done this, it hasn't made a difference. I already had the three options you listed, just when I click on Design, the pane does not respond. Would it be a problem with my PC?

    It could be some reason related your PC or VS2015 , Though before processed for next step I want to confirm few more things. 

    Have you tried to create some windows based application and see still facing design view options, If yes then first suggestion to try to repair your VS 2015. 

    And if still have issue then raise a ticket to Microsoft Support team for help.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, November 29, 2015 6:14 PM
  • Repairing Visual Studio did the trick. I should have thought of that earlier. Thank you a lot for your help.
    Sunday, November 29, 2015 6:45 PM