none
WCF-Oracle DB Adapter RRS feed

  • Question

  • I am trying to insert a row into oracle db using oracle send adapter. Everything works fine locally, but on server it is failing with

    System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    Server stack trace:

       at System.Reflection.Module._GetTypesInternal(StackCrawlMark& stackMark)

       at System.Reflection.Assembly.GetTypes()

       at Microsoft.Adapters.OracleDB.OracleDBConnectionFactory.LoadUdtAssemblies(String UserAssembliesLoadPath)

       at Microsoft.Adapters.OracleDB.OracleDBConnection.Microsoft.ServiceModel.Channels.Common.IConnection.BuildHandler[TConnectionHandler](MetadataLookup metadataDictionary)

    UDT Schema defined and deployed on server and also gac'ed.

    EnableBiztalkCompatabilityMode : true, UseAmbientTransaction:False

    Using 32 bit host instance, Oracle 11.2g

    Tried every option available, but still not able to get it work.

    Finding help here to get it resolved ASAP..

    Thank.....

    Monday, January 12, 2015 3:41 PM

Answers