locked
Intellisense not working in Expression Editor in Orchestration RRS feed

  • Question

  • Friends,

    i am unable to get intellisense in Expression Editor in Orchestration in Visual Studio 2012.

    Anyone faced this issue and knew how to fix this?

    Note my followign observations:

    1. we are building the solution with incomplete orchestration development, it does have errors (but we wanted to build it to autoupdated nuget pacakges). It should not matter for intellisense i believe.

    2. when we take latest code from TFS and open for the first time, the intellisesse seem to work (not very confirm). But once we build the solution we do not get intellisense. 

    Any ideas how to troubleshoot this?


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Thursday, October 15, 2015 12:43 PM

Answers

  • Atlast i found the issue. 

    in the suborchestrations, multi part ports have been created with same name as in main orchestration.

    Hence orchestration is confused due to ambiguity and unable to populate intellisense.

    After renaming them to remove ambiguity, intellisense is back to normal.


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 1:23 PM

All replies

  • Hi Ravindar,

    It should work after build the solution too. Need one confirmation, Is it working in CS file?

    If not please start from step 1 and Move to next when the earlier one doesn't work for you, hope one of them will solve the problem;

    1. Close all the tabs and open your file again. (Thanks to russds)
    2. Clean the Build > Close the Solution > Restart Visual Studio > Open the Solution again
    3. Goto:  Edit > IntelliSense > Refresh Local Cache
    4. Close Visual Studio 2012 and delete this folder: %AppData%\Microsoft\VisualStudio\11.0\ReflectedSchemas
    5. Goto: TOOLS > Import and Export Settings > Reset all settings
    6. Delete .suo file in the project folder.

    Thanks, If my reply is helpful please mark as answer or vote as helpful.


    Thursday, October 15, 2015 2:35 PM
    Moderator
  • thanks for the reply.  i do not see .suo file in project folder.  i could see biztalk project file and tfs source control file.


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Thursday, October 15, 2015 4:26 PM
  • Thanks for confirming the point #6, have you tried above other steps? And Is it working in CS file ?

    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Friday, October 16, 2015 3:52 AM
    Moderator
  • I am unable to find IntelliSense option under Edit when i open solution.

    1. Goto:  Edit > IntelliSense > Refresh Local Cache

    also the following folder does not exist

    %AppData%\Microsoft\VisualStudio\11.0\ReflectedSchemas


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 4:54 AM
  • The SUO file is a hidden file, which is placed in the same folder as the SLN file. It contains a lot of information such as which files are currently open in the IDE, some local settings, etc.

    Edit > IntelliSense > Refresh Local Cache, It should come when open CS file in edit mode.

    %AppData%\Microsoft\VisualStudio\11.0\ReflectedSchemas, Please confrim which version of VS are you using?

    For VS2010: %AppData%\Microsoft\VisualStudio\10.0\ReflectedSchemas

    For VS2012: %AppData%\Microsoft\VisualStudio\11.0\ReflectedSchemas

    For VS2013: %AppData%\Microsoft\VisualStudio\12.0\ReflectedSchemas


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Friday, October 16, 2015 5:31 AM
    Moderator
  • Please check below settings too,

    Under the Tools >> Options >> Text Editor >> All Languages >> General you might see that the Statement completion items are half checked (square). Uncheck 'Auto list members' and 'Parameter information' and check them again.

    This fix should work with any version of Visual Studio 2008, 2010, 2012 and 2013.

    Still having problems? Then see Using Intellisense on MSDN for other troubleshooting suggestions.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Friday, October 16, 2015 5:44 AM
    Moderator
  • Ok thank you.

    By the way in .CS files the intellisense is working. Only problem with Biztalk project files.(Orchestration)

    And yes under General, those two properties are checked (enabled)


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 6:08 AM
  • This issue is only with a particular BizTalk solution.

    Other BizTalk solutions are workign fine, i am able to get the intellisense


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 12:18 PM
  • Atlast i found the issue. 

    in the suborchestrations, multi part ports have been created with same name as in main orchestration.

    Hence orchestration is confused due to ambiguity and unable to populate intellisense.

    After renaming them to remove ambiguity, intellisense is back to normal.


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 1:23 PM
  • Thanks Kamlesh, your points too helped for troubleshooting the issue. I voted them.

    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Friday, October 16, 2015 2:51 PM