none
downloading .NET Framework 3.5 (2.5 & 3.0) RRS feed

  • Question

  • so I have a few games that I have downloaded that required 3.5, I have tried to install it but I get the error 0x8007002 which means that the specified file could not be found. I look into the programs and features option and it is clearly there. I have tried to do the on/off procedure. I have tried trouble shooting the files/windows update. I have tried disabling 4.5 before installing 3.5. and the error keeps coming up and it bothers me that I am paying 15-60 dollars to a game to find out that it requires 3.5 to play. that is a complete waste of my money. its bad when some issue like that occurs that drives me away from wanting to purchase a game that I would like to play only to find out that I cant play it even after spending entire nights of googling and watching youtube videos on how to fix this issue. everyone else seems to have there same issue resolved with simple tasks but they do nothing for mine. and its hard to believe that there are no recent solutions for the same issue as if people are no longer having this issue. I just want this to be fixed and have been dealing with this issue for over 6 months

    Sunday, July 21, 2019 10:03 PM

All replies

  • I am assuming you are using windows 10 or 8.1.  I would go to turn on windows features and check .net 3.5 and install it that way
    Monday, July 22, 2019 12:55 AM
  • Hi Mytharian,

    Welcome to the MSDN forum.

    According to your error code "0x80070002", you can try the following methods:

    (1)    Please make sure to connect to Internet

    l  select Task Manager->Service->click “open services” at the bottom -> find “Windows updates “and right click and select properties --- change the "startup type" from manual to automatic, save the settings, and then click Apply.

    l  Open Control Panel-->Programs and Features->Select turn Windows features on or off-->Check the .net framework3.5 checkbox, wait for the download and install, restart the computer.

    (2)    repair damaged Windows files

    l  Run the "sfc /scannow"  on the CMD

    l  Run the DISM tool to repair the Windows Update errors

    Run the command:DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:C:\RepairSource\Windows /LimitAccess

    Replace the C:\RepairSource\Windows placeholder with the location of your repair source.

    (3) Modify registry information

    l  Start --> Run --> Type regedit-->HKEY_LOCAL_MACHINE-->SOFTWARE-->Microsoft-->Internet Explorer-->Right-click MAIN, select Permission-->Select User, change to "Allow full control"

    l  Reinstall .net framework3.5

    If this issue persists, please feel free to let us know.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, July 22, 2019 7:25 AM
    Moderator