none
Mount Azure Storage Error 87

    Question

  • I am currently testing Azure Storage because I have to introduce it to 5 potential clients. I have run into a problem though.

    Using net use <drive-letter>: \\<storage-account-name>.file.core.windows.net\<share-name> /u:<storage-account-name> <storage-account-key>

    I get an error "System Error 87 has occurred", "The parameter is incorrect". When I try to connect from Windows 7 (probably won't work) and Windows 10 computers on our domain. If I try from our 2008R2 and 2012R2 server the drive is added in a flash and works really well.

    I have tried to disable the Firewall on Windows 10 but still get the same error. When I test the open ports on the computers it actually reports that port 445 is closed.

    The port is open at our ISP and I am certain that is must be something on the Windows computers as they are on the same network/hardware firewall as the servers.

    Any suggestions?


    • Edited by Winoto Saturday, December 31, 2016 9:36 AM
    Saturday, December 31, 2016 9:27 AM

All replies

  • Hello Winoto,

    According to this:

    https://docs.microsoft.com/en-us/azure/storage/storage-dotnet-how-to-use-files

    You'll need a SMB 3.0 version of Windows (Windows 8 or Windows Server 2012 at least).

    Port 445 must be open for outbound (from on-premises to Azure) only.

    Use http://SysInternals.COM tools (download SysInternals Suite) and try

    PSPING <storage-account-name>.file.core.windows.net:445

    and see if it works. If it doesn't, you need to sort your outbound firewall.

    Hope this helps.

    Cheers.


    André Melancia | Developer / DBA / Microsoft Certified Trainer (MCT) | Andy.PT

    Sunday, January 1, 2017 12:12 AM
  • I am connecting from a Windows 10 and I have used powershell to enable all SMB. If you read my initial post you can see that port 445 is open in our hardware firewall and our servers both 2008 and 2012 can map the drive properly.

    This is a problem with Windows 10 because port 445 seems to be closed, as I wrote in my problem description. Firewall has been disabled on Windows 10 but I still get a response that the port is closed.

    !. All computers and servers are on the same network!

    2. It works from the servers but not from Windows 10 systems.

    3. I have used https://support.microsoft.com/en-us/kb/2696547 to ensure that SMB 3 is enabled.

    4. Windows 10 reports port 445 as closed even when firewall is disabled.

    5. I have the same problem from my Windows 10 at home, but the servers in my testcenter can map the drive!

    So my suspicion is that there is something in Windows 10 acting up (port 445).

    Tuesday, January 3, 2017 7:35 AM
  • Hi,

    Could you email us at azurefiles at microsoft.com? We'd like to follow up with you to investigate.


    Mine
    Tuesday, January 3, 2017 7:32 PM
  • Sure, just get this error when trying :)

    AzureFilesPM@microsoft.com
    Remote Server returned '< #5.7.133 smtp;550 5.7.133 RESOLVER.RST.SenderNotAuthenticatedForGroup; authentication required; Delivery restriction check failed because the sender was not authenticated when sending to this group>'<o:p></o:p>

    Wednesday, January 4, 2017 6:33 AM
  • Could you reach out to azurefiles at microsoft.com?
    Also, did you try looking at this article?
    https://docs.microsoft.com/en-us/azure/storage/storage-troubleshoot-file-connection-problems#error-53-or-error-67-when-you-try-to-mount-or-unmount-an-azure-file-share
    In order to check if port 445 is open, try running:
    >PortQry.exe -n [storage account name].file.core.windows.net -p TCP -e 445

    Thank You

    Rena Shah


    This posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, January 4, 2017 11:51 PM
  • Rena Shah, please try to read my initial post and replies. Windows 10 reports that port 445 is closed!

    Also I can't contact you on azurefiles because I get the previously mentioned error!

    Thursday, January 5, 2017 6:22 AM
  • Just solved the problem by using CMDKEY as suggested by a friend :)
    Friday, January 6, 2017 9:05 AM
  • Glad you are able to get this to work. Did you solve your issue by using the command for persisting storage credentials? cmdkey /add:<storage-account-name>.file.core.windows.net /user:<storage-account-name> /pass:<storage-account-key>

    Thank You

    Rena Shah


    This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, January 9, 2017 9:58 PM
  • CMDKEY: Credential added successfully. But still not able to map the Azure file share.

    C:\Users\pandadu>cmdkey /add:testpeerstorage.file.core.windows.net /user:testpee
    rstoage /pass:ub4lGluF7L+7ilCcR2QPk9bQo5rb9oeSs5SBp0jJtFBQ4yD9nBCrG3isYvdrzN/lkv
    i5iWkQCwh+wbPTKsuQRA==

    CMDKEY: Credential added successfully.

    C:\Users\pandadu>net use M:  \\testpeerstorage.file.core.windows.net\fileshare /
    u:testpeerstorage
    System error 53 has occurred.

    The network path was not found.


    Tuesday, January 10, 2017 1:40 PM
  • Looks like port 445 is blocked. Have you been able to successfully mount the share even once? Cannot definitively say, but you might have to work with your ISP or company's IT support to unblock the outbound port 445 for Azure Files. We resolved the issue with the email address azurefiles at Microsoft.com. Do you want to reach out to us one-one?

    Thank You

    Rena Shah


    This posting is provided "AS IS" with no warranties, and confers no rights

    Tuesday, January 10, 2017 8:36 PM
  • Yes, One on One would be the better option. I tried all but no luck.

    Referred below link as well -

    https://docs.microsoft.com/en-gb/azure/storage/storage-dotnet-how-to-use-files#mount-the-file-share

    Wednesday, January 11, 2017 4:07 PM
  • Do you want to retry sending an email to azurefiles at microsoft.com

    This posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, January 11, 2017 5:55 PM
  • I have the same problem. Any solution for this?
    Thursday, January 12, 2017 2:20 PM
  • did anyone get success on <g class="gr_ gr_5 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="5" id="5">that ?</g>

    I've just got that working or using Microsoft Azure Storage Explorer and accessing the file shares from a guest VM in Azure IAAS but when I watch the videos at channel9 and Azure sites it seems to me that we can access the file shares through the internet? am I wrong?

    


    Thiago Beier Se foi &#250;til marca como resposta! Don&#180;t forget to mark as answer!

    Wednesday, July 26, 2017 7:26 PM
  • Are you getting any error message when accessing the Azure file share from your on-premises machine?

    Azure File storage offers network file shares in the cloud using the industry standard Server Message Block (SMB) Protocol and Common Internet File System (CIFS)Azure File shares can be mounted concurrently by clients such as on-premises deployments of Windows, macOS, Linux, or by Azure Virtual Machines. A general-purpose storage account gives you access to Azure File Storage and other services such as Blobs, Azure virtual machine disks, Queues under a single account.

    For more information refer the below link:

    https://docs.microsoft.com/en-us/azure/storage/storage-files-introduction

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Monday, July 31, 2017 5:39 PM
    Moderator