locked
ReportViewer.RefreshReport does nothing RRS feed

  • Question

  • I have a simple Form with a ReportViewer in it.

    I have a SQL Server on my network with report services running.

    I can navigate to the server/reportserver and see the report I want to run.  I click and it loads great in my browser.

     However I can't get the ReportViewer in my form to do anything.

    I set the values like so.

            private void tsbRunReport_Click(object sender, EventArgs e)
            {
                ReportViewer1.ServerReport.ReportServerUrl = new Uri("http://saphire/reportserver");
                ReportViewer1.ServerReport.ReportPath = "Daily Sales by Location";
                ReportViewer1.RefreshReport();
            }//Tree View Select

    The Refresh command comes back immediately and the control does nothing.  The site currently does not require credentials and there is no exceptions thrown.

    I have also tried with crendentials and still no responses or exceptions.

    The control just shows "The source of the report definition has not been specified".  Which I believe is what I am doing in the code.

    I didn't post this in the Reporting forum because the report works fine.  Its the control that is giving me troubles.

    Thanks


    • Edited by Voast Dev Thursday, April 26, 2012 1:00 AM
    Wednesday, April 25, 2012 11:53 PM

Answers

  • Figured it out.  I had to have ProcessingMode set to Remote.
    • Marked as answer by Voast Dev Thursday, April 26, 2012 1:08 AM
    Thursday, April 26, 2012 1:08 AM

All replies

  • Figured it out.  I had to have ProcessingMode set to Remote.
    • Marked as answer by Voast Dev Thursday, April 26, 2012 1:08 AM
    Thursday, April 26, 2012 1:08 AM
  • Wouderful!


    Ghost,
    Call me ghost for short, Thanks
    To get the better answer, it should be a better question.

    Thursday, April 26, 2012 9:58 AM