locked
Azure data factory - copy activity - Azure blob to SFTP is not working RRS feed

  • Question

  • Hi All, 

    We are getting below exception while moving the files from Azure blob to SFTP.  

    Error Message : 

    { "errorCode": "2200", "message": "ErrorCode=SkipMissingFileNotSupportedForNonDirectBinaryCopy,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Skip missing file is not support in current copy activity settings, it's only supported with direct binary copy with folder.,Source=Microsoft.DataTransfer.ClientLibrary,'", "failureType": "UserError", "target": "XXXXX", "details": [] }

    Source Dataset : Binary type

    Target Dataset : Binary type

    Reference screen shot: we are not setting fault tolerance 

    Regards,

    Anbumani M

    Thursday, May 21, 2020 1:55 PM

Answers

  • Hi Anbumani M,

    Thanks for reaching out. Could you please try to clear your browser's cache, close and open your browser and go to ADF pipeline in ADF UI, and please verify if you were able to see below "skipErrorFile" property in JSON Code of your pipeline. If it exists, please remove it from code and test your pipeline and see if the issue resolves. 

    Please remove below code from your pipeline:

    "skipErrorFile": {
                                        "fileMissing": false,
                                        "fileForbidden": false
                             }

    If you are still experiencing the same issue after removing "skipErrorFile" property, please email below details to azcommunity@microsoft.com for further investigation.

    Email subject: <Attn - Kranthi : MSDN Thread title>

    Thread URL: <MSDN Thread>

    Subscription ID:  <your subscription id>
    Data Factory Name : <ADF name>
    ADF pipeline Name: <Pipeline name>

    ADF Region : <Region of you data factory>
    pipeline run ID: <failed pipeline run ID>
    Attach Support files : Download Azure Data Factory support files



    Please let us know how it goes. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, May 21, 2020 8:33 PM
  • Hi KranthiPakala, 

    It is working properly. 

    Thank you so much. 

    Regards,

    Anbumani M

    • Marked as answer by Anbumani M Friday, May 22, 2020 4:55 AM
    Friday, May 22, 2020 4:55 AM

All replies

  • Hi Anbumani M,

    Thanks for reaching out. Could you please try to clear your browser's cache, close and open your browser and go to ADF pipeline in ADF UI, and please verify if you were able to see below "skipErrorFile" property in JSON Code of your pipeline. If it exists, please remove it from code and test your pipeline and see if the issue resolves. 

    Please remove below code from your pipeline:

    "skipErrorFile": {
                                        "fileMissing": false,
                                        "fileForbidden": false
                             }

    If you are still experiencing the same issue after removing "skipErrorFile" property, please email below details to azcommunity@microsoft.com for further investigation.

    Email subject: <Attn - Kranthi : MSDN Thread title>

    Thread URL: <MSDN Thread>

    Subscription ID:  <your subscription id>
    Data Factory Name : <ADF name>
    ADF pipeline Name: <Pipeline name>

    ADF Region : <Region of you data factory>
    pipeline run ID: <failed pipeline run ID>
    Attach Support files : Download Azure Data Factory support files



    Please let us know how it goes. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, May 21, 2020 8:33 PM
  • Hi KranthiPakala, 

    It is working properly. 

    Thank you so much. 

    Regards,

    Anbumani M

    • Marked as answer by Anbumani M Friday, May 22, 2020 4:55 AM
    Friday, May 22, 2020 4:55 AM
  • Hi KranthiPakala, 

    It is working properly. 

    Thank you so much. 

    Regards,

    Anbumani M

    Ideally, you should mark Kranthi's reply as answer (not your own reply) 

    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    Friday, May 22, 2020 8:57 AM