Run-time error '429' ActiveX component can't create object RRS feed

  • Question

  • Hi!
    I get the error (Run-time error '429' ActiveX component can't create object)
     when I execute my VB 6.0 program on Windows server 2003
    BUT not on Windows XP Professional.

    The code that causes error is:
    Set wrkJet = CreateWorkspace("", "admin", "", dbUseJet)

    Is there anybody who experienced the same problem? What should I do?



    Thursday, December 29, 2005 10:47 AM


  • Hi again!

    I have solved my problem! So nice!
    I have added reference to Microsoft DAO 3.6 Object Library instead of Microsoft DAO 3.51 Object Library in my project and it works now both on Windows Server 2003 and on Windows XP Professional.


    Friday, December 30, 2005 8:55 AM

All replies

  • I am betting that Access isn't installed on the server
    Friday, December 30, 2005 6:24 AM
  • Hi again!

    I have solved my problem! So nice!
    I have added reference to Microsoft DAO 3.6 Object Library instead of Microsoft DAO 3.51 Object Library in my project and it works now both on Windows Server 2003 and on Windows XP Professional.


    Friday, December 30, 2005 8:55 AM
  • how to access??
    Tuesday, July 11, 2006 11:22 AM
  • I am getting the same error message when attempting to install an application which i believe was written in visual basic.  It installs fine on my XP machine.  The error comes up when installing to my new machine with Vista Home Premium.  Please advise.


    Wednesday, September 12, 2007 9:20 PM
  • I can not install the programmes I have paid for and installed on my XP machine which I no longer have, instead I have Vista Home Premium and I continue to receive the message above.

    Could you please inform me of a solution to this problem.

    Kind Regards

    Wendy Dipple


    Thursday, October 11, 2007 5:02 AM
  • HI All,


    I'm getting the same error. Its working fine in Windos XP, but error when trying in windows server 2003.

    the error is in the code



    Set objBD = New BrowseDialog


    with message box

    run time error '429'

    ActiveX component can't create object



    Looking at previous replies. I tried after adding "Microsoft DAO 3.6 Object Library", but the result is same.



    Could any one help me out, by giving reply how to get rid of this.


    Tuesday, November 27, 2007 9:17 AM

    I have a tlb component for VB6 that I wrote in VS2008 that displays reporting services reports. When I run the vb6 application in vista, it works fine (this is where I wrote and built the application).


    Whe I run the VB6 application in windows XP with the same tlb component registered into the VB6 application, I get the same error as everyone above.


    run time error '429'

    ActiveX component can't create object


    I would assume there is some compatibility confilct with Vista com component and windows xp components,


    Does anyone know a way around this apart from building the tlb application on vista for vista installs and another separate build for xp machine installs????




    Thursday, February 7, 2008 10:44 PM
  • i re-registered the scrrun.dll and all works fine now

    same results also on vista




    Monday, April 21, 2008 12:42 PM
  • Hi,

    I am using win 7 with VB6 and getting error 429:Activex cannot be created.I have done all the steps described above but still getting the eroor.

    Can somene please help me.

    Tuesday, January 5, 2010 10:20 PM
  • This solved "Error: ActiveX component can't create object" on Windows Vista for me. Thanks!

    Tuesday, January 12, 2010 11:04 AM
  • Hi,

    Can you tell me how you did this step by step?


    Sunday, March 21, 2010 5:30 PM
  • I am using win 7 and facing this problem getting error 429:Activex cannot be created

    would anyone tell me how to fix in in detail many many thanks.



    Tuesday, June 29, 2010 2:31 PM
  • I've been searching for a fix for this error for over three months (!!!) and re-registering scrrun.dll worked for me. I was installing a vital project scheduling/tracking app which runs an Access DB. I could not get it reinstalled after trying to upgrade, and this 429 error would pop up during the installation.

    I went through a host of other fixes found on the web: uninstalling/reinstalling Access and Office, re-registering DAO dlls, running registry cleaners (did nothing), updating VB Runtime files and Windows Script Host or whatever... can't say for sure if it was the combination of everything I did PLUS re-registering scrrun.dll, but the error didn't disappear and I wasn't able to complete the install until I re-registered it.

    I found the dll in C:\WINDOWS\system32 folder (WinXP Pro) and used RegSvr32 to register. Got my app back. *whew*

    Tuesday, October 5, 2010 10:36 PM
  • I ran into this issue as well on some sort of insurance/actuarial type of application.

    I fixed the issue by going to the install folder of the software, found a dll file in there, re-registered it, and the app worked fine after.

    For anyone else who may run across this error, you should do the same to see if that fixes the issue.


    Friday, November 19, 2010 2:17 PM
  • Hi there,

    Im also get into this ActiveX component can't create object issue. Here's my story.

    I run my project into two W7. One is clean and one is installed with everything about vb6, crystal report, and third party component. With the clean W7 occurred this ActiveX while the other one can works fine. I've try the solution mentioned upper but no luck. Do u guys got any idea about it?

    Thank you very much.

    /PS : This program can run well in XP.

    Tuesday, December 21, 2010 1:41 AM
  • I use scrrun.dll and prog is perfectly run


    rajesh mittal

    Tuesday, March 15, 2011 1:49 PM
  • thanks rajesh mittal.... its working
    Monday, March 28, 2011 6:38 AM
  • I have a little program Wheelkwys that was working fine for a year, then a few months ago got "Run-time error '429'".

    I use Windows XP.

    I followed your idea and found scrrun.dll in Windows\System32\. I opened a Command Prompt window and used RegSvr32. Now Wheelkeys works.

    I'm glad you posted this info. Thanks.

    Sunday, May 15, 2011 10:44 PM
  • SOLVED and posting in the hope this helps someone:  I got this error while recovering an asp and VB app from backups of a failed server, onto a new server.  One test server ran the app fine, but the new server that I built specifically for it got this error.  The difference?  The test server that ran the app ok had lots of other software on it, and therefore had the runtime support the app needed.  Many docs pertaining to this error center around the possibility that the creator of the application did not package all of the runtime support needed to support the software.  My problem was centered around database access, and I knew that the old server had MS SQL Server Express on it - so I added that to the new server even though I was recovering the db to our main db server instead of a local instance.  One error went away, but the app still didn't work.  What other product adds a lot of runtime support to a machine?  MS Office!  I installed that (2007 version) and the app now runs fine.  Thinking that I had perhaps overdone it with the MS Office install, I tried removing that but the app broke again.  I am going to name the app here just so search engines pick this up:  It was an outdated version of Scheduler Plus ii from CEO Software, and I think it also uses the PeopleCube name. 


    Charlie Prothero

    Tuesday, December 18, 2012 11:54 AM