none
install failed - uninstall failed RRS feed

  • Question

  •  

    I tried to upgrade to SPS 3.0 from SharePoint Team Services that this server came installed with.
     
    When asked to choose between "gradual upgrade" or "in-place upgrade", I wrongly chose "in-place upgrade". Only later I found out that it was the wrong option. (I am still mad about this : why ask me an option with a possible so wrong answer in the first place)
     
    First I tried to continue with the upgrade anyway : I updated SPS from WindowsUpdate, and then ran the SharePoint Products and Technologies Configuration Wizard (who invents these names ?). This wizard failed at the last step, step 31 of 31 :"[SPManager] [ERROR] [10/10/2007 9:23:32 PM]: The pre-upgrade scan tool has not yet been run on this database SPContentDatabase Name=STS_jana_1 Parent=SPDatabaseServiceInstance Name=MICROSOFT##SSEE. You must run the pre-upgrade scan tool before you can continue with the upgrade process. Run the tool from the following path: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\prescan.exe."
     
    I waited a few days and then decided to uninstall the lot from the Control Panel-Add and Remove Programs. This failed and left SPS in a corrupt state.
     
    Meanwhile the automated backups which contained the system state before the SPS installation had been overwritten, so I could revert to the state before the uninstall but not to the state before the SPS installation.
     
    Now I am trying to finish the installation, using the SharePoint Products and Technologies Configuration Wizard. I first ran the prescan tool : no problem detected.
     
    Then I ran the SharePoint Products and Technologies Configuration Wizard again, with a new failure :"Failed to register SharePoint Services".
     
    From the log file I read :
    10/20/2007 18:52:25 7 INF Calling SPServiceInstance.Provision for instance Microsoft.SharePoint.Search.Administration.SPSearc hServiceInstance, service Microsoft.SharePoint.Search.Administration.SPSearc hService10/20/2007 18:52:45 7 ERR Task services has failed with an unknown exception 10/20/2007 18:52:45 7 ERR Exception: System.ArgumentException: The object with id dd6d44c0-943a-4e02-90b5-abf4fcca9a18 does not exist in the configuration store. The object may have been deleted by another operation. at Microsoft.SharePoint.Administration.SPConfiguratio nDatabase.DeleteObject(Guid id) at Microsoft.SharePoint.Administration.SPConfiguratio nDatabase.DeleteObject(SPPersistedObject obj) at Microsoft.SharePoint.Administration.SPPersistedObj ect.Delete() at Microsoft.SharePoint.Search.Administration.SPSearc hServiceInstance.ProvisionDatabase() at Microsoft.SharePoint.Search.Administration.SPSearc hServiceInstance.Provision() at Microsoft.SharePoint.PostSetupConfiguration.Servic esTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject) at Microsoft.SharePoint.PostSetupConfiguration.Servic esTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject) at Microsoft.SharePoint.PostSetupConfiguration.Servic esTask.InstallServices(Boolean provisionTheServicesToo) at Microsoft.SharePoint.PostSetupConfiguration.Servic esTask.Run() at Microsoft.SharePoint.PostSetupConfiguration.TaskTh read.ExecuteTask()
     
    Please help.
    How to finish this installation, or how to uninstall it ? Either way I am happy.

     

    Monday, October 22, 2007 12:50 PM