none
Kinect slows down when debugging on depth data RRS feed

  • Question

  • On my laptop Kinect I working ok but on my workstation application slows down but only when working with depth stream and only in VS – when I run same app outside VS it runs fast???

    Thursday, June 30, 2011 1:05 PM

Answers

  • I was forced to do quick reinstall of my OS and now everything works.

    Ps.  Application works even compiled in debug mode when running outside VS – but in VS depth data cause slow motion

    Thursday, July 7, 2011 8:46 AM

All replies

  • Do you run into this problem whether you have a lot of programs open or whether VS is the only program running? Depth and skeletal processing is fairly resource intensive, and since you're using it in a multitasking environment rather than a dedicated one, resources have to be shared with everyone else in the system, which could degrade performance of kinect processing pipeline.

    Hope this helps,
    Eddy


    I'm here to help
    Friday, July 1, 2011 1:45 AM
  • 1.       This problem exists even on clean system

    2.       This problem exists on my pc which is rater power machine and doesn’t exists on my laptop

    3.       There are only depth (no skeleton) data enabled

    4.       There is no data in Output window in VS

    5.       Laptop and PC have Windows 7 x64 onboard

    6.       Problem only exists in debug mode

    Friday, July 1, 2011 9:16 AM
  • Oh, about point 6 above, you're saying that problem only happens when you compile "Debug" configuration rather than "Release" configuration, right? If so, what is the frame rate you see when compiling in one config vs the other?

    Interesting data to know, since the binaries released with SDK are all compiled in "Release" mode, and that's where most of the work is happening, so I wouldn't have expected so much performance difference based on how you compile your code. Do you have a lot of code yourself, or is it a small app?

    Thanks for sharing your experience!
    Eddy


    I'm here to help
    Thursday, July 7, 2011 2:09 AM
  • I was forced to do quick reinstall of my OS and now everything works.

    Ps.  Application works even compiled in debug mode when running outside VS – but in VS depth data cause slow motion

    Thursday, July 7, 2011 8:46 AM
  • Thanks for letting me know. I've marked your last post as answer for reference.

    Eddy


    I'm here to help
    Thursday, July 7, 2011 7:20 PM