locked
Multiple CGI/ FastCGI instances RRS feed

  • Question

  • User-529253680 posted

    Hi

    As my previous thread (as referred in below link) in this subject was closed and the issue is still existing, I am staring a new one.

    https://forums.iis.net/t/1233522.aspx?Multiple+CGI+FastCGI+instances

    So far we made our site to run with PHP 5.3 and so no issues. As we got alert from our hosting support that we are running a old PHP version, we changed again to PHP 5.6. So the same issue started again

    As Jean Sun suggested, kindly suggest a  value to set the Max Instances,

    Thanks

    Thursday, October 27, 2016 12:01 PM

Answers

  • User-529253680 posted

    Hi

    Finally we disabled WinCache (1.3.7.1) through php.ini, now the issue seems to be fixed. Any way I will confirm this after seeing one week

    Thanks

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, November 18, 2016 4:31 AM

All replies

  • User-460007017 posted

    Hi sierratec,

    It seems that there are something wrong with your configure in IIS to handle the different version of PHP.

    You could try the steps in following link:

    http://ruslany.net/2009/12/multiple-php-versions-on-the-same-iis-server/ to enable the IIS to allow PHP5.6 while the PHP 5.3 has been used before.

    You may need to reset the FastCGI setting and use a handler to enable the PHP 5.6.

    Best Regards,

    Yuk Ding

    Friday, October 28, 2016 6:19 AM
  • User-529253680 posted

    HI Yuk Ding

    Thanks we will try on this and get back

    Friday, October 28, 2016 6:56 AM
  • User-529253680 posted

    Hi Yuk Ding

    We hosted our site in Accuweb server VPS. So they have already installed both the PHP versions for us (5.3 and 5.6). So as suggested in the reference link we checked the handler mapping. Please find the screenshot. Please suggest if this is correct.

    Thanks

    Tuesday, November 1, 2016 11:27 AM
  • User-529253680 posted

    Hi

    Till now the issue is not yet resolved.

    When we checked event viewer we got error as below. Could you kindly suggest on this.

    Error

    Faulting application name: php-cgi.exe, version: 5.3.28.0, time stamp: 0x52a782bd

    Faulting module name: KERNEL32.DLL, version: 6.2.9200.16859, time stamp: 0x53118550

    Exception code: 0xc0000005

    Fault offset: 0x00026157

    Faulting process id: 0x417c

    Faulting application start time: 0x01d23e480a99bc53

    Faulting application path: C:\Program Files (x86)\PHP\v5.3\php-cgi.exe

    Faulting module path: C:\Windows\SYSTEM32\KERNEL32.DLL

    Report Id: 54a0b5cd-aa3d-11e6-9421-00163e273088

    Faulting package full name:

    Faulting package-relative application ID:

    Thanks

    Friday, November 11, 2016 7:20 AM
  • User-529253680 posted

    Hi

    Finally we disabled WinCache (1.3.7.1) through php.ini, now the issue seems to be fixed. Any way I will confirm this after seeing one week

    Thanks

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, November 18, 2016 4:31 AM
  • User-529253680 posted

    Hi

    Till now we do not have any issues.

    Thanks

    Wednesday, November 23, 2016 12:29 PM
  • User-460007017 posted

    Hi sierratec,

    Apologize for my late reply for your post. I'm glad that your problem has been resolved. Could you mark your post as answer? So that more people could use your solution to resolve the problem. :D

    Best Regards,

    Yuk Ding

    Friday, November 25, 2016 7:57 AM