none
Losing SSL certificate binding on all websites upon IISRESET on IIS 7 RRS feed

  • Question

  • Hi, 

    I need some guidance on an issue that is really proving difficult.  Everytime I do an iisreset my ssl certificate loses its binding to all websites.  I have 3 web sites and they all running on the same IP and same port 443 and sharing one common certificate which is an intermediate certificate for hbt.ca domain. It support following 3 domains

    www.hbt.ca, apps.hbt.ca, board.hbt.ca

    I am trying to add a host header and ssl certificate to a site.  I have tried using the following:

    netsh http add sslcert ipport=xxx.xxx.xxx.22:443 certhash=af9842b0ac1f99ef382d59e6f28b7e273b6eadbc appid={4dc3e181-e14b-4a21-b022-59fc669b0914}


    appcmd.exe set config -section:system.applicationHost/sites /+"[name='SharePoint Central Administration v3'].bindings.[protocol='https',bindingInformation='xxx.xxx.xxx.22:443:testQA']" /commit:apphost

    When I run netsh http show sslcert it shows that the certificate has been bound.  Also when I look at iis and look at the bindings of this web site it shows it has been bound.  Every time I do an IISRESET the binding is lost.  When I go look at bindings there is no ssl certificate associated with the site.  I have to hit the drop down list and choose one or netsh http add sslcert command.  That ssl will stay associated fine until I do an iisreset again.

     Thanks a Bunch!

    Tuesday, September 27, 2011 11:54 PM

All replies