locked
Why can't Xbuild recognize SignAndroidPackage when using bamboo? RRS feed

  • Question

  • User288359 posted

    I am trying to create a .APK file in Bamboo using the xbuild executable in a command task. The way I thought it should work is like this:

    CusomterApp.sln /t:SignAndroidPackage /p:Configuration=Release This however when I run the build will give this error. Target named 'SignAndroidPackage' not found in the project. I have tried to build it without it but I am getting other errors instead. I have tried changing the order of it and changing the target but it doesn't seem to create the apk file doing this.

    I have seen in another question that someone created an apk file using this(not on Bamboo):

    xbuild $ANDROID_PROJECT_FILE /t:SignAndroidPackage /p:Configuration=Release So I thought I should have no problems with using this on Bamboo but the executable doesn't seem to recognize the SignAndroidPackage and doesn't work, any ideas on how to fix this?

    I create a .IPA file for an IPhone app using mdtool, with this command-v build -t:Build "c:Release|iPhone" CustomerApp.sln and this works fine for creating the .IPA file so I would have thought that the .APK would be fine too.

    Wednesday, January 4, 2017 12:24 PM

All replies

  • User288359 posted

    I have found a problem that when I try to build the apk file using this: /p:Configuration=Release CustomerApp.sln it gives me the error PCL assemblies not installed and it also has this warning : Unable to find framework corresponding to the target moniker '.NetPortable,Version=v4.5,Profile=Profile78'. Framework assembly references will be resolved from the GAC, which might not be the intended behaviour. I don't know why this is happening as I looked for the profile in the folder specified and it was there. I had this problem before when trying to use xbuild to create the IPA file but then I used mdtool and it worked fine, I think I need to use xbuild to build the apk file but I can't see how to fix it. I also tried to run it in the terminal of the mac and I got the same error. Why is this happening?

    Thursday, January 5, 2017 11:02 AM