none
NuGet in Visual Studio community 2015 RRS feed

  • Question

  • Whenever, I open Visual Studio 2015 I get  a Microsoft Visual Studio message box

    NuGet operation failed

    NuGet.Config is not valid XML PATH:

    'C:\Users\Michael\AppData\Roaming\NuGet\NuGet.Config'.

    ".",hexadecimal value 0x00, is an invalid character. Line 1, position 1.

    I can not open the config file in any text editor. It open in Visual Studio as hexadecimal numbers.

    I tried downloading and install NuGet and still the same results, and the same with uninstalling and reinstalling Visual Studio 2015 community.

    This problem seems to have occurred after setting up Visual Studio for developing C/C++ applications.

    Thanks

    Mike W

    Sunday, May 15, 2016 3:00 AM

Answers

  • Hi MKWILSON,

    I recommend you to try to delete NuGet.Config from:

    C:\Users\Your_Username\AppData\Roaming\NuGet\

    After that when you reopen your Visual Studio Community 2015 a new NuGet config file will be created and hopefully your issue will be resolved and gone.

    Hope this was helpful for you..

    Best regards!


    (If this was helpful for you, vote for it and propose it as an answer)

    Sunday, May 15, 2016 1:34 PM

All replies

  • Hi MKWILSON,

    I recommend you to try to delete NuGet.Config from:

    C:\Users\Your_Username\AppData\Roaming\NuGet\

    After that when you reopen your Visual Studio Community 2015 a new NuGet config file will be created and hopefully your issue will be resolved and gone.

    Hope this was helpful for you..

    Best regards!


    (If this was helpful for you, vote for it and propose it as an answer)

    Sunday, May 15, 2016 1:34 PM
  • Dear Mike,

    Welcome to the MSDN forum.

    According to the error message, please have a try with Aimir’s solution. Manually delete the NuGet.Config file from the folder ‘%APPDATA%\NuGet’, then reopen VS to see if the same issue will occur or not.

    You can also have a look at this similar issue: http://stackoverflow.com/questions/36760277/nuget-package-not-working-in-visual-studio-2015

    Anders’s solution: Do you have any nuget.config file in your Solution?

    The format has changed from fx:

    <settings>

      <repositoryPath>..\..\packages</repositoryPath>

    </settings>

    To:

    <configuration>

      <config>

        <add key="repositoryPath" value="..\..\packages" />

      </config>

    </configuration>

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Almir VukMVP Monday, May 16, 2016 6:14 PM
    • Unproposed as answer by Almir VukMVP Monday, May 16, 2016 6:14 PM
    • Proposed as answer by Almir VukMVP Monday, May 16, 2016 6:14 PM
    Monday, May 16, 2016 6:29 AM
    Moderator
  • None of the suggestions resolved this issue for me.  Luckily, I use Git so was able to simply revert all changes and start over

    -- d.

    Wednesday, September 6, 2017 11:03 PM
  • Hi _db_,

    Welcome to the MSDN forum and thank you for your sharing.

    If you have any other issues about the .NET Framework setup in the future, please feel free to let us know.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, September 7, 2017 1:41 AM
    Moderator