locked
Trying to publish with FTP (need configuration opinion/suggions) RRS feed

  • Question

  • User-1727019647 posted

    IIS7 with FTP7 on server2008 64bit

    The pasv port range set from 5000-10000 with the firewall Ip field blank

    I can connect over command line ftp, but not with FileZilla. My FileZilla settings are to attempt PASV.

    status:                      Resolving address of nthost1.abac.com

    <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p> </o:p>

    Status:                      Connecting to 66.226.89.239:21...

    <o:p> </o:p>

    Status:                      Connection established, waiting for welcome

    message...

    <o:p> </o:p>

    Response:                 220 Microsoft FTP Service

    <o:p> </o:p>

    Command:                 USER kanien

    <o:p> </o:p>

    Response:                 331 Password required for kanien.

    <o:p> </o:p>

    Command:                 PASS *********

    <o:p> </o:p>

    Response:                 230 User logged in.

    <o:p> </o:p>

    Command:                 OPTS UTF8 ON

    <o:p> </o:p>

    Response:                 200 OPTS UTF8 command successful - UTF8 encoding

    now ON.

    <o:p> </o:p>

    Status:                      Connected

    <o:p> </o:p>

    Status:                      Retrieving directory listing...

    <o:p> </o:p>

    Command:                 PWD

    <o:p> </o:p>

    Response:                 257 "/" is current directory.

    <o:p> </o:p>

    Command:                 TYPE I

    <o:p> </o:p>

    Response:                 200 Type set to I.

    <o:p> </o:p>

    Command:                 PASV

    <o:p> </o:p>

    Response:                 227 Entering Passive Mode (66,226,89,239,214,5).

    <o:p> </o:p>

    Command:                 LIST

    <o:p> </o:p>

    Response:                 150 Opening BINARY mode data connection.

    <o:p> </o:p>

    Error:                        Connection timed out

    <o:p> </o:p>

    Error:                        Failed to retrieve directory listing

    <o:p> </o:p>

     

    <o:p> </o:p>

    The connection shows established.

    Thursday, November 6, 2008 7:56 PM

Answers

  • User1064866747 posted

    try to FTP in Active mode instead of passive. In your FTP client get connection settings and select 'Active Mode'.

     

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, November 9, 2008 11:01 AM

All replies

  • User-1853252149 posted

    Sounds like a firewall issue.  Is the server's firewall running?  If so, stop it and test.

    Jeff

    Friday, November 7, 2008 9:22 AM
  • User989702501 posted

    Can you try command line ftp.exe to connect?

    your log is showing it failed at passive mode.

    Sunday, November 9, 2008 1:53 AM
  • User1064866747 posted

    try to FTP in Active mode instead of passive. In your FTP client get connection settings and select 'Active Mode'.

     

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, November 9, 2008 11:01 AM