none
Errors from .NET RRS feed

  • Question

  • Hello - I installed realplayer on my XP Pro laptop and ever since I cannot run many apps.  One of the errors is that the following file is missing. 

    C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll

    I tried re-installing .NET v2 and it failed saying a later version was already installed.  Then I tried installing .NET v2 SP1 and just got a generic installation error about the installation failing.

    Do I need to uninstall all versions of the .NET framework and then reinstall them?  (I think I'm up to 3.5 now.)

    Thanks

    Sunday, October 9, 2011 4:38 PM

Answers

  • Hi Alexander -

    Thanks for your kind reply.

    Yep, did all those things.  None of them worked.

    It turns out the very simple solution was to delete the \WINDOWS\WinSxS\Policies   folder as outlined in the link below.

    http://social.msdn.microsoft.com/forums/en-US/netfxbcl/thread/47c93410-2ee2-4dd1-812a-04475d50de7c/

    Would recommend that Microsoft consider adding that very simple solution as part of the clean up tool if at all possible.  Would have saved days of needless downtime, and from the comments from others on that same thread, it would have saved them a lot of time too.

    Also, I wonder if you guys could consider cleaning up or replacing the following kb: http://support.microsoft.com/kb/908077

    It purports to describe how to manually clean up the framework.  However,

    1.  It doesn't mention deleting the Policies folder

    2.  It references a tool that Microsoft no longer provides or supports. 

    Kind regards

     

     

    • Marked as answer by junk1958a Wednesday, October 12, 2011 3:46 AM
    Wednesday, October 12, 2011 3:45 AM

All replies