none
Problem after installing Visual Studio 2015 Update 1

    Question

  • Today I updated Visual Studio 2015. Update 1. After that I got some problems with starting the Visual Studio. Screenshot attached. As result, no templates in New Project dialog.

    I tried to clean folder

    ... AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache.

    And I reinstalled Visual Studio. But it didn't help me.
    What is the problem? Before that I had only one problem :) Designer didn't work.
    How to solve this problems?

    Thanks for you help!
    Tuesday, December 1, 2015 1:54 PM

Answers

  • In my case the problem was solved.

    1. Open c:\Users\{User_Name}\AppData\Local\Microsoft\VisualStudio\14.0\devenv.exe.config
    2. Change binding redirection for System.Collections.Immutable, newVersion should be 1.1.37.0 (not 1.1.36.0).

    <dependentAssembly>
            <assemblyIdentity name="System.Collections.Immutable" publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
            <bindingRedirect oldVersion="1.0.27.0-1.1.65535.65535" newVersion="1.1.37.0"/>
    </dependentAssembly>

    source:

    http://stackoverflow.com/questions/31547947/packages-not-loading-after-installing-visual-studio-2015-rtm

    Also I had to correct the same code in file

    C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe.config

    Wednesday, December 2, 2015 5:48 AM

All replies