none
Issue with WCF Service RRS feed

  • Question

  • Recently we deployed our existing WCF service on Windows 2012 R2 (with 4.6 framework). When I'm trying to run it on port 443 (basically no other ports are binded), I'm getting the following issue

    Could not find a base address that matches scheme http for the endpoint with binding Default. Registered base address schemes are [https].

    Appreciate your response.

    Friday, August 18, 2017 3:58 PM

All replies

  • usually it' must be bound for some applications in under normal usage, It's offen bound in Microsoft service like report service or else ( You could find some articles by google.)

    Unless it 's boned  by virus that you don't know. otherwise no port will be bound by no application run.


    Saturday, August 19, 2017 5:16 AM
  • Run the following from an elevated command prompt:

    netstat -ab

    You wiil find the whole net status.

    Saturday, August 19, 2017 5:21 AM
  • By the way, You need to stop serivce if port is bound by Micrsoft application service. Then you could use this port that you want.
    Saturday, August 19, 2017 5:23 AM
  • https must set [SSL]  up to every kind of server service such as IIS, apache, rails(If you use).
    Saturday, August 19, 2017 5:26 AM
  • Refer this https://www.codeproject.com/Articles/36705/simple-steps-to-enable-HTTPS-on-WCF-WsHttp-bindi
    Sunday, August 20, 2017 11:19 AM
  • Hi Prasad,

    Do you publish to IIS? Did your web side bindings enable http 80 port?

    Which URL did you use when getting this error? I suggest you check whether you enable “<serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>”.

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 21, 2017 3:09 AM