locked
Upgrade/Copy database from 2000 to 2005 RRS feed

  • Question

  • Hi folks,

    I am looking to upgrade a database from MS SQL Server 2000 to MS SQL Server 2005. MS SQL Server 2005 is sitting on a different server than SQL Server 2000. In Microsoft SQL server management studio, I created new database corresponding to the name of the database I want to copy from SQL Server 2000. After that, I right-clicked on database, X let's say, and chose "Tasks" -> Copy Database.

    Source Server: I clicked Browse. Since the 2005 database is not in the the same server I chose Network Server tab. A Drill-Down Database Engine showed up and I chose the name of the server where the database X is (SQL Server 2000)

    I created a temp_superuser account in SQL Server 2000 with full privilages.

    Using SQL Server Authentication in SQL Server 2005 and using the created temp_superuser account, I am getting this error:

    "An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (Provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.) (Microsoft SQL Server, Error: 10061)"

    I am thinking this maybe a firewall problem but my networking knowledge is very limited. How do you think I should go about fixing this error OR upgrading the database from 2000 to 2005?

    Thursday, March 25, 2010 7:25 PM

Answers

  • Go to, Start >> Programs >> Microsoft SQL Server 2005 >> Configuration
    Tools >> SQL Server 2005 Surface Area Configuration >> Surface Area
    Configuration for Services and connections.

    Within this check whether "Local and remote connections" is choosen.
    If not choose it :)

    - Open the "SQL Server Configuration Manager" (under Configuration Tools)
    - Expand the "SQL Server 2005 Network Configuration"
    - Select the "Protocols for "
    - Set the Named Pipes To Enabled

    Regards,

    Sharjeel Ashraf

    Thursday, March 25, 2010 7:48 PM

All replies

  • Go to, Start >> Programs >> Microsoft SQL Server 2005 >> Configuration
    Tools >> SQL Server 2005 Surface Area Configuration >> Surface Area
    Configuration for Services and connections.

    Within this check whether "Local and remote connections" is choosen.
    If not choose it :)

    - Open the "SQL Server Configuration Manager" (under Configuration Tools)
    - Expand the "SQL Server 2005 Network Configuration"
    - Select the "Protocols for "
    - Set the Named Pipes To Enabled

    Regards,

    Sharjeel Ashraf

    Thursday, March 25, 2010 7:48 PM
  • Here is an artical for moving DB with backup and restore functionality:

    I thought that might be helpful.

    http://twinklekumar.wordpress.com/2008/06/29/move-sql-server-2000-database-to-2005/

    Regards,

    Sharjeel Ashraf

    Thursday, March 25, 2010 8:06 PM
  • Actually "Local and remote connects" is chosen and Name Pipes are set to Enabled. I think the config work I need to do is at the server I need to copy the database from namely the config work, if any, needs to be done on the SQL server 2000 - this is the target machine actively refusing the connection!
    Thursday, March 25, 2010 9:34 PM