none
Visual studio 2015 folder

    Question

  • I think I have got some misconfigured in Visual Studio 2015 since every time I create a new project I get a folder at the same level as the solution file called "visual studio 2015" with the following subfolders:

    ArchitectureExplorer

    Backup Files

    StartPages

    I guess this is something in my settings - how can I changed it?

    Thanks

    A

    Thursday, November 10, 2016 11:09 AM

Answers

  • Many thanks for your help Sara, however, I have now found the issue:

    The registry key VisualStudioLocation at HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0 had been changed (definitely not by me directly: I have no need to modify the registry). The value VisualStudioLocation had been changed from c:\users\xxxx\documents\Visual Studio 2015 to simply Visual Studio 2015.

    The only "dubious" thing that I have done that I can think of is to install the Visual Studio 2017 CTP.

    Anyway, with that key correct, I am no longer creating folders named "Visual Studio 2015" all over my disk.

    A

    Tuesday, January 17, 2017 9:40 AM

All replies

  • Hi AMS-Park,

    Welcome to the MSDN forum.

    Refer to your description, it looks like when you create new project and this solution folder be created under the same parent folder with Visual Studio 2015 folder like the following screenshot:

    If so, open VS and File-New-Project and on the New Project screen, please take care of the Location at the bottom of this windows, it is used to define the parent folder where we store this New project/solution as below. If the default value is “C:\Users\username\Documents\” and you are not modifying, then you will get the current behavior. You can change it to the “C:\Users\username\Documents\Visual Studio 2015\Projects” and try it again. Once it works fine, the location will keep this updated value when you create a new project next time.

    If I have any misunderstanding, please let me know, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 11, 2016 6:21 AM
    Moderator
  • I don't think your description is what is happening. Here is what I do to create a new project:

    As you can see, I set the folder correctly in the Wizard, but still a Visual Studio 2015 folder is created. It also gets created when I open any existing solution with a C++ project. Interestingly this does not happen for a C# console application.

    Any help appreciated

    Thanks

    A.

    • Edited by AMS-Park Wednesday, December 14, 2016 11:36 AM
    Wednesday, December 14, 2016 11:35 AM
  • Hi AMS-Park,

    Thank you for your update and sorry for my misunderstanding.

    I tried to reproduce your issue follow your description, but failed, there is no folder ‘Visual Studio 2015’. To check if the customized setting that caused this issue, please have a try with reset setting to the default as below:

    Go to Tools-Import and Export Settings… and select ‘Reset all settings’, then save your current settings, then click ‘Finish’ button to reset the customized setting to the default, it can help us to excludes the customized setting caused this issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, December 15, 2016 2:01 AM
    Moderator
  • I get an error when I try to reset the settings and the problem is not solved when I click close:


    Any other ideas?

    Thanks

    A

    Tuesday, January 10, 2017 4:14 PM
  • Hi A,

    Thank you for your update.

    Refer to the error message, please go to Tools-Option--Projects and Solutions and check the project templates location and item template location like the following, it is the local or a network share?

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 11, 2017 8:12 AM
    Moderator
  • These are all set to local drives and all the folders exist:


    • Edited by AMS-Park Monday, January 16, 2017 4:15 PM
    Monday, January 16, 2017 4:14 PM
  • Hi A,

    Could you please have a check with the following template folders and remove the existing folders under those folders:

    C:\Users\xxxxx\Documents\Visual Studio 2015\Templates\ProjectTemplates\Visual C++ Project

    C:\Users\xxxx\Documents\Visual Studio 2015\Templates\ItemTemplates\Visual C++ Project

    Then try to create a new C++ project to check this issue again.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, January 17, 2017 8:06 AM
    Moderator
  • Many thanks for your help Sara, however, I have now found the issue:

    The registry key VisualStudioLocation at HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0 had been changed (definitely not by me directly: I have no need to modify the registry). The value VisualStudioLocation had been changed from c:\users\xxxx\documents\Visual Studio 2015 to simply Visual Studio 2015.

    The only "dubious" thing that I have done that I can think of is to install the Visual Studio 2017 CTP.

    Anyway, with that key correct, I am no longer creating folders named "Visual Studio 2015" all over my disk.

    A

    Tuesday, January 17, 2017 9:40 AM
  • Hi A,

    I'm so glad to hear that your issue is solved and thank you so much for your sharing, it will help other community members who meet the same or similar issue.

    >>The only "dubious" thing that I have done that I can think of is to install the Visual Studio 2017 CTP.

    I also checked this registry key on my 2 computers who have installed VS 2015 and VS 2017 RC, the key looks like normal and not be changed. I will note this useful information, in case other community members meet the same issue in the future.

    BTW, if you think your reply is helpful, please mark it as answer, that will help others to easier search this useful solution, thank you for your support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 18, 2017 1:43 AM
    Moderator