none
Cannot installe Biztalk LOB adapter SDK SP2 for 32 bit and 64 bit. Please help! RRS feed

  • Question

  • Hi,

            I am working on a 64 bit Windows 2008 Server. I have been trying to installBiztalk Adapter Pack SDK SP2. The system allows me to install only one version 32bit OR 64 bit. I tried installing

    32 bit first and then 64 bit

    64bit first and then 32bit

     

    In both the cases, the first one installs without any problems. When I try to install the second one, I get the following error.

    Another version of WCF LOB Adapter SDK already exists. Remove existing WCF LOB Adapter SDK  through Add/Remove programs and try installing again.

    We already have the Adapter Pack installed (32 bit and 64 bit). Does that cause an issue?

    Please help!

    thanks.

    Friday, September 17, 2010 9:50 AM

Answers

  • You dont need to install both 64 and 32 bit versions of LOB Adapter SDK. On 64 bit machine, you need to have 64 bit version of LOB ADapter SDK.

    However, For adapter pack, you need both 32 bit and 64 bit versions to be installed on a 64 bit machine. This applies to client libraries too.

    Hope this helps!

     

    • Marked as answer by curious_mind Friday, September 17, 2010 2:55 PM
    Friday, September 17, 2010 10:06 AM
  • The Adapter Pack SDK in x64 is working fine - no need for the x86 SDK.

    Only the Adapter pack itself (!) needs to be installed x64 and x86.


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    • Marked as answer by curious_mind Friday, September 17, 2010 2:55 PM
    Friday, September 17, 2010 1:25 PM

All replies

  • You dont need to install both 64 and 32 bit versions of LOB Adapter SDK. On 64 bit machine, you need to have 64 bit version of LOB ADapter SDK.

    However, For adapter pack, you need both 32 bit and 64 bit versions to be installed on a 64 bit machine. This applies to client libraries too.

    Hope this helps!

     

    • Marked as answer by curious_mind Friday, September 17, 2010 2:55 PM
    Friday, September 17, 2010 10:06 AM
  • The Adapter Pack SDK in x64 is working fine - no need for the x86 SDK.

    Only the Adapter pack itself (!) needs to be installed x64 and x86.


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    • Marked as answer by curious_mind Friday, September 17, 2010 2:55 PM
    Friday, September 17, 2010 1:25 PM