none
System.ValueTuple pacakge not properly downloaded from nuget. RRS feed

  • Question

  • Hi,

    I have a solution which is referencing System.ValueTuple package from Nuget gallary. I am trying to build(it restores the nuget packages) this solution from multiple machines, but it is giving me reference error for this package on some machines while working fine on some.

    As per my research, Nuget is creating different named folders inside the System.ValueTuple folder inside packages folder.

    Folder which is working for me - packages\System.ValueTuple.4.3.0\lib\net45

    Folder which is not working fine for me - packages\System.ValueTuple.4.3.0\lib\netstandard1.0

    This is the problem area, we are actually stuck on finding the solution. Please suggest the possible solution.

    Thanks

    Vinod


    • Edited by Vsinghal7 Wednesday, June 14, 2017 11:41 AM Made some changes.
    Wednesday, June 14, 2017 11:17 AM

All replies

  • Hi Vsibghal7,

    Thank you for posting here.

    When you install System.ValueTuple, it will download many versions for different frame version. They will save in different folder.


    When you install from NuGet manager package, there is no need to add reference for the project. It will add the suitable version for project automatically.

    The first folder which is working for you means your project is using .net framework.

    The second folder which is not working for you means it is not the suitable version for project.

    Please do not add reference from folder after you install it via NuGet manager package. Everything will be okay after you install it.

    Best Regards,

    Wendy 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, June 16, 2017 5:14 AM
    Moderator