locked
Trying to import a ready App Service Certificate to a Web App results in a obscure undescriptive error RRS feed

  • Question

  • Having aquired a App Service Certificate (Wildcard), and configured properly (the status is "Issued" and it says "Certificate Ready"), when trying to import it to a Web App (Standard App Service Plan), it results in an error saying: "Failed to add App Service certificate to the app, Check error for more details". 

    The Web App already has already assigned a Hostname matching the certificate CN

    No more details can be found anywhere. Only clientNotification-ba3aef68-5333-4287-a3f2-2730554bb009

    Tried several times during two days with the same result.

    We exactly followed the same procedure in a similar setup some weeks ago without any problem.

    Any advice?


    Thursday, August 4, 2016 9:03 AM

All replies

  • Hi,

    Thank you for posting here!

    Could you please check the complete error message which appeared on the notification?

    Have you done domain verification status successfully?

    Suggest you to check the articles Configure an SSL Certificate and Using Certificates in Azure Web Apps if you have missed any steps.

     

    Regards,

    Ashok

    Thursday, August 4, 2016 5:42 PM
  • Thanks for yor reply!

    Yes, we followed the steps stated at these articles. In fact, we already did this in other similar setups with success.

    There is no more information we can find about the error message:

    TITLE
     
    Add the App Service Certificate to app.
    DESCRIPTION
     
    Failed to add App Service certificate to the app, Check error for more details.
    STATUS
     
    Error
    TIMESTAMP
     
    Fri Aug 05 2016 10:12:51 GMT+0200 (Hora de verano romance)
    UTC TIMESTAMP
     
    Fri, 05 Aug 2016 08:12:51 GMT
    CORRELATION IDS
     
    clientNotification-71cc6d47-49a8-43ff-b03e-070795f6600b
    PERCENT COMPLETED
     
    100

    The certificate is verified. It says:

    "Certificate Ready" : You have completed the necessary configuration steps, certificate has been issued and is now ready for assignment.

    Thanks!

    Friday, August 5, 2016 8:25 AM
  • Hi,

    When you say it is succeeded with other deployments, what are the changes you have made with the particular certificate? Looks like issue is with the certificate.

    If issue still persists with the particular certificate suggest you to contact support to understand and debug the issue.

     

    Regards,

    Ashok

    Monday, August 8, 2016 6:12 PM
  • We are experiencing this exact same issue.

     
    Failed to add App Service certificate to the app, Check error for more details.

    With no further detail available, as above out certificate says it is ready, I've rekeyed and still the same issue remains.

    Tuesday, September 13, 2016 10:10 AM
  • Hello,

    We would request you to create a Technical Support Ticket as our engineers would need to work with you on the issue and would require more details like your Subscription and/or other PII details. This would be beyond the purview of the Forums Support.

    Here is the link http://azure.microsoft.com/en-us/support/options/ to create support case.

     

    Regards,

    Ashok
    Wednesday, September 14, 2016 4:32 PM