locked
Migration Desktop LS application from VS 2013 to VS 2015 RRS feed

  • Question

  • Hello everyone,

    Beginning of this week, my customer told me that they needed extra functionnality on a LS application developped 4 years ago.

    Last year i already migrated from 2012 to 2013 and it was fine. When i dug in my laptop to find the solution and started it with VS2015, the upgrade worked fine so far.

    Issue is that when i start the app like this, the application opens and white page.

    I have no errors coming from VS, in the event viewer i have this : 

    Request information: 
        Request URL: http://localhost:49299/Services/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo 
        Request path: /Services/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo 
        User host address: ::1 
        User:  
        Is authenticated: False 
        Authentication Type:  
        Thread account name: WORK\clement
     
    Thread information: 
        Thread ID: 5 
        Thread account name: WORK\clement
        Is impersonating: False 
        Stack trace:    at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
       at System.ServiceModel.Activation.ServiceHttpModule.EndProcessRequest(IAsyncResult ar)
       at System.Web.HttpApplication.AsyncEventExecutionStep.OnAsyncEventCompletion(IAsyncResult ar)
    

    I checked on internet didn't find a real solution so far but indeed when i try to access my Microsoft.LightSwitch.SecurityData.svc i get an error : 

    Request Error
    The server encountered an error processing the request. See server logs for more details.

    I didnt find any logs related to this on my laptop (using iis express).

    Anyone has a hint here ?
    I would like to avoid having to manually migrate everything to a new solution ...

    Thanks a lot,

    Clément



    Friday, February 3, 2017 9:41 AM

All replies

  • Hi clement,

    This link have a reference with the similar case of yours:

    https://social.msdn.microsoft.com/Forums/en-US/c7621252-552f-48d8-a6f7-5744f0a007df/the-server-encountered-an-error-processing-the-request-see-server-logs-for-more-details?forum=lightswitchhtml

    Best Regards,

    Yuk Ding

     

    Friday, February 10, 2017 9:38 AM