none
Shortcut F8 for debug step into is not working RRS feed

  • Question

  • Hi All,

    Thanks for looking into it.

    Shortcut F8 for debug step into is not working. When I press F8 nothing happens. The screen is standstill and code statement does not execute. I googled and couldn't find a solution that works for me. 

    There is no error message as well.

    Wednesday, December 4, 2019 9:41 AM

All replies

  • Are you using a laptop? If so, you may have to press Fn+F8.

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Wednesday, December 4, 2019 12:09 PM
  • Thanks for reply. Yes Ia m using laptop but Fn+F8 is for the other option - projector/screen options which pop up from right side of the screen.
    Thursday, December 5, 2019 12:30 AM
  • Are you sure that you clicked inside the procedure that you want to execute?

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Thursday, December 5, 2019 8:53 AM
  • Are you sure that you clicked inside the procedure that you want to execute?

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Yes Hans, I have been using F8 since last 9 years or so. I have checked this at least 20 times since yesterday.

    This seems a very weird problem to me as I cannot find people who have faced this before.
    Thursday, December 5, 2019 9:41 AM
  • To: S...
    re:  stepping into

    Does your code (sub/function) have arguments?
    If so the code must be called and the arguments supplied.
    -OR-
    Is something selected on a worksheet/chart?
    '---


    Some new, some older Excel programs (now free) at MediaFire...
    Download from...
    http://www.mediafire.com/folder/lto3hbhyq0hcf/Documents

    Thursday, December 5, 2019 12:39 PM
  • To: S...
    re:  stepping into

    Does your code (sub/function) have arguments?
    If so the code must be called and the arguments supplied.
    -OR-
    Is something selected on a worksheet/chart?
    '---


    Some new, some older Excel programs (now free) at MediaFire...
    Download from...
    http://www.mediafire.com/folder/lto3hbhyq0hcf/Documents

    Hi..Thanks
    No to both the questions.
    Friday, December 6, 2019 6:59 AM
  • The module could be corrupted.
    Copy the entire contents of the module into Notepad.
    Delete the module.
    Insert a new module.
    Copy everything in Notepad and paste into the new module.

    Also, breaking very large modules into two or more modules could help.

    Friday, December 6, 2019 10:43 AM
  • My issue is resolved after I repaired office 365 twice and restarted my laptop like 5,6 times in 3 days.
    Monday, December 9, 2019 1:24 AM