none
Cannot successfully flash Windows CE 6.0 on WM8505 laptop RRS feed

  • Question

  • Hi there, this is my first posting with you guys and so thank you all for viewing it.  Hopefully you can help me out here coz this issue has me at breaking point.

    I've been asked to restore one of those little 7" Notebook clone things you can get from eBay for about $100.  It has Windows CE 6.0 on it, but it won't boot up or do very much at all.

    I have successfully downloaded a Windows CE 6.0 Script and placed it on a 2gb SD Card and while this goes through all the motions of updating the wee notebook and does bring me into the WinCE desktop, it then shows an error stating:

    -------------------------------------

    Auto Format
    Is Auto Format Flash Disk
    Auto format NAND Flash after 3s

    -------------------------------------

    AutoRun
    System Disk no existed!

    -------------------------------------

    At this point, I click Ok and I can navigate around Windows CE, but I can't do very much.  If I take out my SD Card and try a reboot, I just get a black screen and nothing else at all.

    I've tried various Script downloads, but I get the same error everytime.

    I've attached a few pictures here showing the process I experience when I attempt this procedure.

    Really hope someone here can suss this one out.  Its probably something stupid that I'm not doing, but I've zero experience with Windows CE and Embedded technologies!

    Many thanks for viewing.  I look forward to your suggestions!

    [IMG]http://i53.tinypic.com/311l8g9.jpg[/IMG]

    [IMG]http://i53.tinypic.com/s1iagy.jpg[/IMG]

    [IMG]http://i55.tinypic.com/9jg7x5.jpg[/IMG]

    [IMG]http://i54.tinypic.com/dgl5hl.jpg[/IMG]

    [IMG]http://i55.tinypic.com/1zlg9sg.jpg[/IMG]

    Saturday, January 29, 2011 9:08 PM

All replies

  • Bugger! It doesn't look like my pic uploads are working at the moment?! No luck today at all! :( LMAO!!
    Saturday, January 29, 2011 9:09 PM
  • Shea:

    What is a Windows CE script?  Windows CE doesn't have a script - your vendor may have one though.

    Are you using Platform Builder?  If not, you need to tell us what you are doing.


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Monday, January 31, 2011 1:37 PM
    Moderator
  • Hi there. Thanks for the reply.

    I really know soooo little about Windows CE!

    After initially searching online for assistance with my issue, I found a site that gave me a link to a 'Script' folder that allows you to reflash the Notebook http://bento-linux.org/wiki/vt8505/wm8505/windows-ce

    With the above folder in place on a SD Card, I could now at least get the notebook to boot up, but when it arrives in Windows CE, it is supposed to complete the flash installation, but it always results in an error relating to 'No system disk'.  I've tried various versions of this Script folder but have had no further luck at all.

    Hope this information gives you something to go on and thanks again for the interest!

    Sunday, February 6, 2011 1:48 PM
  • Shea:

    We can't see what you see, so when you state "an error relating to", we don't know what it actually said or meant.  If you tell us what it actually said, we might be able to help more.  

    What I suspect it means is that the $100 eBay deal wasn't such a good deal.  It may have faulty or missing hardware.  On the otherhand, it may be as simple as BIOS settings that have disabled an internal disk.


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Sunday, February 6, 2011 3:39 PM
    Moderator
  • Bruce,

    Kindly click on the links below to see pics of each stage as I see it.  Thank you!

    http://i53.tinypic.com/311l8g9.jpg

    http://i53.tinypic.com/s1iagy.jpg

    http://i55.tinypic.com/9jg7x5.jpg

    http://i55.tinypic.com/1zlg9sg.jpg

     

    Just to recap, this little notebook isn't mine, it belongs to a customer who bought this of ebay and brought it to me soon after to see if I could get it going again (apparently, it was working when they first bought it).

    Thanks again

    Tuesday, February 8, 2011 8:03 PM
  • I am having the same problem.  I can't get any support from Microsoft, and it appears that absolutely no one on this earth has a solution for this.  I think we are just plain out of luck Shea. :(  I'm throwing the paperweight in the trash.
    Thursday, February 10, 2011 11:46 AM
  • Hi. Please don't throw it away, I would love to have it and attempt to fix it. Please. Although I might be asking a little too much as I live in Cape Town, South Africa. (I'll pay for the postage though :D)
    Saturday, February 12, 2011 11:34 AM
  • Microsoft is not responsible for the problem, so you shouldn't expect them to support it.

    The HARDWARE vendor should support you though.  You should contact them before giving up.  The problem that we and Microsoft have with helping you is that we don't know anything about the hardware.


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Sunday, February 13, 2011 2:59 PM
    Moderator
  • Unlike the other people here i know a lot about these wm8505 wince netbooks

    you will have almost no chance of reflashing it with ce i suggest andriod, but it will only work if you have the script version, just have all the files in the script folder format the sd and put the script folder on to the sd card then away you go, there is also no way to platform build a ce and put it on these they have been disabled of that option.

    i have searched the net for weeks and only just found an english version of windows ce but it will not flash these devices, it will boot and work well but it runs in RAM From the script files on the sd.

    something to do with the software not recognising the NAND Flash disk so get andriod.

    cheers

    Tuesday, May 24, 2011 3:26 PM
  • i had the exact same problem as you!!

    i found a solution and it was because that specific image wasnt for that type of notebook.

    go to this link and download the software update:

    http://www.sylvaniacomputers.com/productsupport.php?prodid=14

    extract the script folder to the root of the SD card and boot the notebook up with it in. it will run automatically like the one you have tried, but will NOT have the error. this install the driver for the wifi, so that does not have to be download seperately.

    Tuesday, May 31, 2011 7:59 PM
  • WinCE doesnt support scripts, what it needs just one Binary OS image(bin) file. Your OSImage needs to compatible with your device, usually there would be default bootloader in your flash memory ,wchich is trying to load valid image from SD or other location.

    Get the updated image(complete .bin file) and place in appropriate location. 

      
    • Proposed as answer by Mukesh_Patel Friday, July 26, 2013 9:28 AM
    Friday, November 23, 2012 5:14 AM