none
Visual Studio for Office breaking down? RRS feed

  • Question

  • I have been working on a C# Excel workbook for about 5 months. It worked great til about a month ago. I think after I installed the .NET 4.5 beta is when the problems started happening. Excel randomly crashes and shuts down, even when code is not executing. For example, it likes to crash when I paste something to my workbook. Sometimes the app will startup okay, other times it will crash on the Excel splash screen. It is just being inconsistent, and does this both in debug testing and when published. I uninstalled .NET 4.5, reinstalled Visual Studio and .NET 4.0, and I'm still getting problems. Any suggestions?
    Sunday, June 10, 2012 10:27 PM

Answers

  • I installed a bunch of Windows updates and it seems to be working fine now. Maybe it was a bug that MS fixed. Thanks! I'll bring this thread up if it acts up again.
    Saturday, June 16, 2012 7:04 PM

All replies

  • Hi Racer,

    Welcome to the MSDN forum!

    " Excel randomly crashes and shuts down, even when code is not executing."

    If you start the excel in safe mode, does paste action work?

    What's the application like? Is the C# Excel workbook an excel add-in? Would you please provide some code for us so that we may look into it?

    Thanks.


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, June 12, 2012 8:36 AM
    Moderator
  • I'll try it in safe mode later and I'll follow up on what it does.

    It's an Excel workbook with C#. It's a personal project I've pursued to learn C# for Office. I copy bank statements into it and it appends the transactions to a local SQL Server database. The other sheets have a variety of reports to evaluate my personal finances, and leverages LINQ to manage the data.

    Not sure what code to include since it crashes without code being executed.

    It's kind of frustrating because not only have I become dependent on this workbook, I want to use C# for Excel at work. But I can't if the performance is buggy.

    Thursday, June 14, 2012 12:51 AM
  • I installed a bunch of Windows updates and it seems to be working fine now. Maybe it was a bug that MS fixed. Thanks! I'll bring this thread up if it acts up again.
    Saturday, June 16, 2012 7:04 PM