locked
Report Viewer ASP.NET session has expired RRS feed

  • Question

  • User-933610287 posted

    I've found many posts about this error in this forum as well as other forums, however I have not found a solution that has worked for me yet.

    My report runs fine in Report Viewer and I can export it to PDF without a problem.  The problem occurs if I try running the report or exporting the report again, only 30 seconds later, I receive the session has expired error.

    • There are no images in the report, so setting "AsyncRendering" to False doesn't work for me.
    • I triedsetting <sessionState cookieless="true" /> in my web.config file but that didn't work either.
    • I tried setting me.session.timeout = 120 on my page_load event but that didn't work.

    All attempts brought me back to the same error.  Hopefully some of the ideas above will help other people, but none have worked for me so far.  Please let me know if someone knows of a  solution/work around to this error.


    Thanks.


    Thursday, March 11, 2010 2:52 PM

Answers

  • User-96295490 posted

    Hi,

          I had faced similar issue, this can be resolved by enabling the autorefresh check box in the report.

    To do this open your report and right click out side the page area in your design tab of the report

    then select Properties and in the general tab enable the checkbox of autorefresh to no of seconds you want the

    page to be refreshed also you can go to Report-Report Properties in the main toolbar.


    This will fix your issue, if you face any problems do ask.


    Regards,

    Anish


    " Mark this as answer if this post helps you it might help others also"


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 2, 2010 8:09 AM

All replies

  • User-96295490 posted

    Hi,

          I had faced similar issue, this can be resolved by enabling the autorefresh check box in the report.

    To do this open your report and right click out side the page area in your design tab of the report

    then select Properties and in the general tab enable the checkbox of autorefresh to no of seconds you want the

    page to be refreshed also you can go to Report-Report Properties in the main toolbar.


    This will fix your issue, if you face any problems do ask.


    Regards,

    Anish


    " Mark this as answer if this post helps you it might help others also"


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 2, 2010 8:09 AM
  • User-933610287 posted

    Thanks for the tip!


    Wednesday, April 7, 2010 2:49 PM
  • User-1883815321 posted

    I also had this problem and setting AutoRefresh certainly helps.

    Thursday, February 23, 2012 3:34 AM