locked
Can not resolve reference: C:/Windows/Microsoft.NET/Framework/v4.0.30319/de/mscorlib.resources.dll RRS feed

  • Question

  • User311346 posted

    Hello, In Debug Mode I get the following error: Can not resolve reference: C:/Windows/Microsoft.NET/Framework/v4.0.30319/de/mscorlib.resources.dll Any ideas?

    Thursday, May 11, 2017 9:05 AM

Answers

  • User13824 posted

    Bugzilla cross-reference update

    Bug 56213, Comment 24 describes a workaround:

    1. On Windows, open the Visual Studio 2017 installation folder. (Default: C:\Program Files (x86)\Microsoft Visual Studio\2017\)
    2. Navigate to MSBuild\Xamarin.
    3. Open the Xamarin.Apple.Sdk.targets file in an editor with Administrator privileges.
    4. At the end of the file you'll find a <PropertyGroup> (line 100). Between the <PropertyGroup> tags add the following line:

      <FrameworkPathOverride>$(TargetFrameworkRootPath)$(TargetFrameworkIdentifier)\$(TargetFrameworkVersion)</FrameworkPathOverride>

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, May 12, 2017 10:17 PM

All replies

  • User138971 posted

    same problem for me, just updatedxamarin for visual studio, using this configuration

    Microsoft Visual Studio Community 2017 Version 15.2 (26430.4) Release VisualStudio.15.Release/15.2.0+26430.4 Microsoft .NET Framework Version 4.7.02046

    Installed Version: Community

    Visual Basic 2017 00369-60000-00001-AA975 Microsoft Visual Basic 2017

    Visual C# 2017 00369-60000-00001-AA975 Microsoft Visual C# 2017

    Xamarin 4.5.0.443 (c871575) Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

    Xamarin.Android SDK 7.3.0.13 (448f54f) Xamarin.Android Reference Assemblies and MSBuild support.

    Xamarin.iOS and Xamarin.Mac SDK 10.10.0.30 (30b6e87) Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

    Thursday, May 11, 2017 9:51 AM
  • User34444 posted

    I get the same error after Upgrading to Visual Studio 2017 Update 2 (15.2)

    There is already an issue tracked in Xamarins Bugzilla and some entries in the Microsoft Forums: 1st 2nd

    Thursday, May 11, 2017 12:26 PM
  • User317001 posted

    Same problem as well when i want to deploy for iOS..

    Friday, May 12, 2017 10:15 AM
  • User919 posted

    Me too !!!!

    Friday, May 12, 2017 10:41 AM
  • User46850 posted

    Me too :(

    Friday, May 12, 2017 12:53 PM
  • User285725 posted

    Me too :( Anyone found a fix for that ?

    Friday, May 12, 2017 5:46 PM
  • User13824 posted

    Bugzilla cross-reference update

    Bug 56213, Comment 24 describes a workaround:

    1. On Windows, open the Visual Studio 2017 installation folder. (Default: C:\Program Files (x86)\Microsoft Visual Studio\2017\)
    2. Navigate to MSBuild\Xamarin.
    3. Open the Xamarin.Apple.Sdk.targets file in an editor with Administrator privileges.
    4. At the end of the file you'll find a <PropertyGroup> (line 100). Between the <PropertyGroup> tags add the following line:

      <FrameworkPathOverride>$(TargetFrameworkRootPath)$(TargetFrameworkIdentifier)\$(TargetFrameworkVersion)</FrameworkPathOverride>

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, May 12, 2017 10:17 PM
  • User323318 posted

    I added the line immediately above the </PropertyGroup> (as line 102) and it worked. Thank you Brendan Zagaeski!

    Saturday, May 13, 2017 10:34 AM
  • User285725 posted

    Thank you so much, it does work :smile:

    Sunday, May 14, 2017 3:11 PM
  • User300426 posted

    Thank you so much, it does work \o/

    Friday, May 19, 2017 6:45 PM
  • User258152 posted

    installing and keeping Xamarin/VS 2017 in a stable mode is now a nightmare!!!! not to speak the other nightmare that is to get it to work for the first time!!

    Saturday, May 20, 2017 2:21 AM
  • User159709 posted

    Worked for me as well :)

    Monday, May 22, 2017 12:18 PM
  • User234119 posted

    Worked for me too

    Saturday, May 27, 2017 2:59 AM