none
run-time error 3035 RRS feed

  • Question

  • i get a "system resource exceeded" error if i run a query using access2013, but if i run the same query using my old access (maybe 2003!), it runs fine...why?!  how do i get it to run using access 2013??
    Tuesday, June 12, 2018 8:02 PM

All replies

  • Hi,

    Are you running this query on the same machine where both versions of Access are installed? Or, are you using two different computers with separate installs of Access?

    Tuesday, June 12, 2018 8:04 PM
  • i am running this query on the same machine where both are installed.  i'm old (ha) and prefer 2003.  i use 2013 to run forms which have a list of underlying queries, but my 2013 stops...and then i run the underlying queries manually in 2003.  which brings me to another separate but related question...if i try to run this same form using 2003, i get an error message that reads "on click...object or class does not support the events."  how can i edit my 2003 to accept this same form that runs fine in 2013 (except that 2013 stops with a run-time error of 3035)?!

    thanks so very much for your help...this is my first time using a forum!

    Tuesday, June 12, 2018 8:13 PM
  • Okay, thanks for the clarification. The first thing we need to remember is opening an Access file created with an older version of Access using a newer version of Access, there could be "automatic" design changes made by the newer version of Access to the file, which could render it useless (or different) when opened again using the older version.

    It is considered best practice to develop using the lowest version number for your supported users.

    Now, if you're merely testing the database file created using an older version for 2013 users, then it's okay - as long as any changes you make to the design is done in 2010 (to avoid messing with your 2010 users).

    For your specific error, I am guessing opening the file in 2013 made Access update your library references, which when opened in 2003 would result in an error because older versions of Access will not recognize the  newer libraries. If so, check your references and reset them back to use the older libraries.

    Hope it helps...

    Tuesday, June 12, 2018 8:19 PM
  • the library suggestion is ringing a bell...i will try that for the older version.  

    as for the original question of "system resource exceeded" with a run-time error of 3035, that i get using 2013...do you know why? and what i can do about it?  i even tried putting in some logic that says on error resume, but it just keeps trying and bombs and retries, staying in that loop.

    Tuesday, June 12, 2018 8:57 PM
  • Sorry, no idea without seeing the query. Are you able to share a copy?

    Just a thought...

    Tuesday, June 12, 2018 9:00 PM
  • sure...i don't quite know how to share, your thoughts?

    Tuesday, June 12, 2018 9:36 PM
  • so let me clarify that my tables are HUGE, ie. each 1 takes up 1,500,000 KB file size and comprises its own database.  so i query 1 table at a time, to put out a subset of data into a new table, in a new database.  the query is lengthy (50 fields wide) but fine, ie. there's no error...even the form works fine..."sometimes"...that's the frustrating part.  so it will stop with a run-time error, and if i resubmit or hit continue, sometimes it will try again and finish and sometimes i just get the error again.  so it seems it's a size or system or memory or ??? constraint.  
    Tuesday, June 12, 2018 9:55 PM
  • sure...i don't quite know how to share, your thoughts?

    Hi,

    One way is to upload to a file share and then post a link here. Probably a good idea to sanitize the data first though.

    Tuesday, June 12, 2018 9:56 PM
  • If the problem only happens occasionally, it would be harder to troubleshoot. But if the problem can be reproduced with some consistency, then it will make things easier. But still, I cannot promise you anything.

    Just my 2 cents...

    Tuesday, June 12, 2018 9:58 PM
  • thanks...
    Wednesday, June 13, 2018 1:27 AM
  • Hello Tugboat222,

    It seems that you are editing a huge recordset in access. If so, please check if solution of below thread which is similar with your issue works for you.

    How do I prevent "Run-time error 3035 System Resource Exceeded"?

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 13, 2018 5:37 AM