locked
GetAuthenticationInfo error publishing after adding new code signing certificate RRS feed

  • Question

  • I updated the certificate in the publishing wizard to use a new certificate (from GoDaddy) for my desktop app.

    I checked "Specify a certificate" and selected my code signing PFX.  I clicked "View Certificate" and the correct info came up.

    The app built and seemed to publish okay.

    Now when I publish my desktop app I just get a white screen.

    I used Fiddler to get this info that is generated when trying to start the app:

    Error in '/' Application
    The resource cannot be found.

    The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /client/Web/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo

    Any ideas would be greatly appreciated.

    Thanks,

    Mark

    Friday, January 16, 2015 1:58 AM

All replies

  • Hi, are you running on a iis server or Azure? If iis, remove the application from iis and redeploy it. Sometimes when making changes like xap the update wont work.

    Sven Elm

    Friday, January 16, 2015 6:53 AM
  • Sven: 

    Thanks for the response, but I am using Azure Cloud Services.  This has been working fine for years until I updated the certificate.

    Mark

    Friday, January 16, 2015 4:54 PM
  • Hi. if you changed the xap cert then you have to remove the app because the app was signed with another cert before. Redeploy after you removed the whole app from Azure.

    Sven Elm

    Friday, January 16, 2015 5:07 PM
  • Sven:

    I deleted the staging deployment from Azure, cleaned my solution, rebuilt and published and I am still getting the error.

    Mark

    Friday, January 16, 2015 5:12 PM
  • Still have the problem.  Does anyone know what might cause:

    Error in '/' Application
    The resource cannot be found.

    The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /client/Web/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo

    Thanks,

    Mark

    Friday, January 16, 2015 10:46 PM
  • Error in '/' Application
    The resource cannot be found.

    The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /client/Web/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo

    Hi Mark,

    A signed XAP file is required for an application that is hosted on Microsoft Azure. Please check whether you add your certificate properly.

    You can add a certificate from the certificate store on your computer or from a network location that the network administrator provides.

    To add a certificate

    1.In the LightSwitch Publish Application Wizard, go to the Security Settings page, choose the Digital Signature tab, and then choose Browse.

    2.In the Select File dialog box, browse to the location of the certificate that you want to use, and then choose the Open button.

    Basic information about the certificate appears. You can choose the View Certificate button to display more information about the certificate.

    Best regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Saturday, January 31, 2015 8:30 AM