64-bit printing (thunking spooler stopped working)


  • after building (64-bit) theXPSDrv sample driver and printing a document in MS Word 2007,
    I get the following error:

    "Thunking Spooler APIS from 32 to 64 Process has stopped working"

    is this a problem with the driver or some other Vista issue?

    Wednesday, June 20, 2007 2:53 AM

All replies

  • same problem here with XP professional 64bit.
    • Proposed as answer by meadowlark Saturday, October 17, 2009 11:26 AM
    Wednesday, June 20, 2007 2:32 PM
  • Is that RTM - 6000 build of Vista / WDK you are seeing the problem?

    Otherwise i dont see any such issue with my XPSDrv (NOT WDK Sample XPSDrv).


    Sunday, June 24, 2007 5:20 AM
  • yup, this is Vista RTM/ WDK 6000

    Any guesses on could have went wrong? Sad
    Tuesday, July 03, 2007 10:47 AM
  • Can you attach a debugger to the crashing process (presumably splwow64.exe) and post a stack trace? This would give a quick clue what might be wrong.


    Typically when there is a crash in splwow64 thunking process, it's the driver that's causing the crash (the splwow64 is a bare-bone GDI thunk dispatcher; there is very little room for the OS to fault here).



    Tuesday, July 10, 2007 3:42 PM
  • I get this error message now with two programs: Quicken Premier 2007 and Random House Unabridged Dictionary for Windows.  The latter program worked perfectly until three days ago under Windows Vista Ultimate.  I suspect some recent automatic updates have had undesirable side effects.
    Sunday, July 15, 2007 2:12 PM
  • I got this error when I wanted to Save my hotel reservation details as PDF file. I was trying to print using ScanCreate PDF when he error popped up. And yes, I am using Vista - a brand new vista user. This is the second problem in a day for me with Vista. God knows how many more I'm going to encounter.


    Any solution to the "thunking" issue?




    Monday, July 23, 2007 5:08 AM
  • Ok I am not sure if this will help anyone else or not.  I was getting this error after working on getting my printer to work through my Vista x64 host OS onto a Virtual XP computer on the same computer.  Was having a problem with the driver "not matching" and said forget it.  I would get the error whenever I tried to open Word 07 and when I tried to print from other office 07 applications but I could print test pages with no problem.  I deleted the printer and reinstalled it with the universal driver for my printer.  My printer is a Konica Minolta 2300DL.  Since reinstalling the driver I can now open and print from any application.  Hope this helps someone...looks like I am far from the only one having this problem.


    Thursday, August 30, 2007 1:11 AM
  • I havent been able to solve it for 6 weeks. It seems to be more common with ultimate. Quicken 8 wont print checks and scans wont print. Where is microsoft on this? Are the asleep? 


    Friday, September 21, 2007 3:26 AM
  • i traced the problem to a possible bug with our print ticket provider. 


    what's your specific problem? are you developing your own printer driver?



    Thursday, September 27, 2007 7:19 AM
  • Are you seeing this with your driver or are you using a 3rd party driver? Thanks!
    - Ashwin
    Thursday, September 27, 2007 5:17 PM
  • this is with the driver we are making.
    Wednesday, October 03, 2007 5:49 AM
  • possible hotfix available for this: http://support.microsoft.com/kb/941962/en-us
    Wednesday, October 31, 2007 8:47 AM
  • Update: see my solution in a later post below. 


    Thanks for posting the link to the hotfix, however unfortunately this hotfix still has no effect on the problem.  Vista 64 continues to freeze up the applications whenever I try to print.  The printing eventually gets through the spooler after several minutes.  It is super slow and a major bug so I hope there will be a fix soon.

    Saturday, November 03, 2007 3:09 AM
  • I have an HP Pavilion with 64 bit Vista Ultimate.  Forget direct printing -- it never works.  If I uninsall and then reinstall Quicken to a folder other than Program Files (x86) I can creat PDF reports a couple of times, before it fails with some i/o message.  If I try to "print" to Paperport I get the Thunking error, then it hangs totally.  Have to power off and restart.  Quicken has been unable/unwilling to fix this.  I think there are not enough 64 bit computers out there to make it worth their while.  Microsoft says it is a Quicken problem and will not look at it.  Does anyone have any ideas!!!


    Friday, December 07, 2007 3:08 PM
  • Update: see my solution in a later mesage below.


    Evidence is increasing that Microsoft has a MAJOR bug in the splwow64.exe process.


    Is anyone from Microsoft out there?  When is this going to be fixed?  This is driving me crazy.  Now I can understand why a lot of people are just keeping Windows XP.

    Friday, December 14, 2007 6:46 AM
  • I'm having major hangup issues with this same error when trying to print a PDF from Adobe Illustrator CS3 and Photoshop CS3. This error is only about a week old for me, but then, I installed Vista 64 about 3 weeks ago.
    Friday, January 11, 2008 3:33 PM
  • I have just started having the same issue, after running Quicken and Paperport on Vista64 Business for the past year.  I thought my problems started when Q2008 installed its 6th revision.  Now I a having the same issues as you report, and my uninstalling and reinstalling programs and drivers does no good.  It seems this is a common problem, per web site reports.  I'd be interested if you found a solution.  I had tried to contact MS for their HotFix that you must ask for by email, but they have not answered me back yet.  Good luck.

    Monday, January 21, 2008 9:40 PM
  • This is definitely a Microsoft problem.  Error happenning when printing from Word 07 on Vista 64 Ultimate.  Just started this morning.


    Tuesday, February 05, 2008 1:05 PM
  • This extremely slow printing in Vista x64 droze me crazy for a year and I found a fix. 


    The Epson R800 creates an audit file called EPAUDF01.AUD in C:\ProgramData\Epson\Printer.


    Delete this file.


    After deleting this file, printing is fast.  It makes an incredible difference. 


    I used the Vista resource monitor to find out what was causing the heavy disk activity when splwow64.exe showed it was thunking the spooler.


    In my case this Epson audit file grew to 36MB.  Now, after deleting, it recreated itself as just 1KB.


    So who's bug is this?


    It seems like both an Epson and Microsoft bug.  It is Epson for creating a large audit file, and Microsoft for having a slow disk write in Vista for whatever mechanism Epson is using to write this file.


    Nice to be able to actually use the printer! 


    Saturday, March 29, 2008 8:13 PM
  • Recently, I installed Vista Business x64 edition on a second hard drive.  I received the good old Thunking Spooler error.  I finally got the hotfix that's suppose to address this issue and tried to install it, but I received another error stating that the hotfix did not apply to my system.  I tried calling Microsoft's support for an hour or so and that was a big joke.  I came in this morning and I was determined to fix the problem for good.  I already had a x64 version of XP on my other hard drive.  Basically, I changed the permissions on the splwow64.exe on the vista install in the windows directory and gave administrators full rights.  Renamed the splwow64.exe to splwow64.exe-old and copied the file from the windows xp x64 edition windows directory to the vista x64 windows directory.  Opened word, no error message.  I can print from all x32 applications with no errors. 
    Monday, May 05, 2008 1:36 PM
  • I recently purchased a new desktop... HP, AMD processor, Windows Vista Home Premium 64 bit, HP Deskjet F4280 printer.  I've never been able to print from any program.  I've had the machine about a week and have looked everywhere for a solution, updated all drivers and software.  I'm not extremely technical, so I chatted with HP support and there suggestions did not help me.  On a whim, I changed the printer processor from hpzpp5mu to hpcpp081.  It worked.  I'm not sure why.  But I figured I'd post this to give someone else help.
    Thursday, July 31, 2008 5:02 AM
  • i have the same issue here on a vista 64 bit ultimate edition. Although mine is a build 6001 with sp1. so maybe they carried the same issue on the newer version?! I am shocked....Smile not!  anyway, anyone have  a solution to this...or should i just take a picture of the document i want to print ? lol

    Saturday, August 02, 2008 2:44 AM
  • I am also getting this error message when trying to print to the Microsoft XPS Document Writer

    and then trying to paste text from the clipboard into Save As dialog for the filename.


    For example, I copy a news headline to the clipboard, print to XPS, and try to use that headline as the filename in the Save As dialog.


    The Save As dialog first locks up with a (Not Responding). and then

    "Thunking Spooler APIS from 32 to 64 Process has stopped working"

    Wednesday, August 06, 2008 3:28 PM
  • Hi


    Eventhou this is an old post, I will giv my reply anyway.


    I had the same problem, using a Xerox copier as the printer.

    So I opend the properties for the printer with "Run as Administrator" a Java applet startet, and Vista came with a block/unblock warning. So I Unblocked this Java thing, and tried to print again, this time I had no problems.


    Hope this might help someone.


    Tuesday, September 16, 2008 12:59 PM
  • I just want to chime in - I have the problem of splwow64 crashing constantly on me, without even trying to print. I have a Canon MX-5500N PS, Fax, and XPS printers installed. I just click the "Send information to Microsoft" button maybe 10 times per day and go on with my business. Of course, printing from any program doesn't work.
    Friday, September 26, 2008 11:47 AM

    yes , yes, yes, I found it for Windows XP 64 bit.

    It was HP Laserjet driver which was causing conflict.

    That had hpzui4wm.dll and hpz6r4wm.dll (Version 61.63.461.42) which was causing splwow64.exe failing.

    Update with the latest printer driver.

    It should resolve it.

    Friday, October 03, 2008 10:01 PM
  • Hi. I'm experiencing this problem, when I try to print to Adobe PDF virtual printer, I get error message about splwow64.exe process. Is there any solution for it, or do you all wait for something? Smile
    Tuesday, October 07, 2008 2:12 PM
  • It's not a solution, but I'm having an identical problem. It's frustrating as I bought first quality gear and software and nobody seems to care.
    Thursday, October 23, 2008 5:05 PM
  • It has to be a driver issue.

    We had same issue too. We had an bad version of driver, so go on the printer company website and download the latest driver.

    Good luck.


    Thursday, October 23, 2008 8:38 PM
  • Hi,

    I have had a HP Pavillion for a couple of months now and for some reason when I try to open any file created on my old 34bit system i get this error and my computer hangs up for 5 minutes then finally opens the file.

    I noticed most people are saying this is happening when printing, I don't have a printer even plugged in or installed right now and I still get it upon trying to open any older file.


    Saturday, November 01, 2008 2:35 AM
  • I have the EXACT same circumstance (HP AMD, Vista Home Premium 64, Deskjet F4280).  I'm at my wits end between the HP people and Vista, and need this ASAPWhere did you find the hpcpp081.dll?  I did a full search and can't find it on my drive or the software CD.  Can you email it to me (kabole@msn.com)?




    Thursday, December 04, 2008 1:58 PM
  • What do you mean, changing the "Printer Processor"?

    Monday, December 08, 2008 10:18 PM
  • When starting Word 2007 I get the same message :-

    "Thunking Spooler APIS from 32 to 64 Process has stopped working"

    Word will start but the message will popup every few seconds.

    The OS is Vista64.

    Tuesday, February 03, 2009 11:34 AM
  •  Here are the steps that you can try to resolve the issue.
    At first restart the spooler service from the services Window then follow these steps
    Open printers folder
    Right click on the printer icon and select properties.
     Click on Advanced tab.
    Select "print directly to printer" Click on Ok

    Then try printin!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    • Proposed as answer by MR--RICK Wednesday, April 22, 2009 1:44 AM
    Sunday, March 15, 2009 12:50 AM

  • "At first restart the spooler service from the services Window then follow these steps
    Open printers folder
    Right click on the printer icon and select properties.
     Click on Advanced tab.
    Select "print directly to printer" Click on Ok "

    Uhm...how does one accomplish this? I am computer-challenged, and haven't a CLUE how to "restart the spooler service".

    I tried the other steps, but I keep getting yet ANOTHER stinking error message about not being able to save my choices..."Error 0x0000070c"!!! :(

    Sunday, April 05, 2009 10:55 AM
  • The Rocker's solution worked for me for a PDF Thunking Spooler error from Excel.

    Wednesday, April 22, 2009 1:45 AM
  • Solution if using print servers:

    If your printer is on a server change it and print to the printer directly.

    Remove the printer, Add a new printer, select local printer, use the ip address for the printer, reinstall the driver when it asks for the printer.

    This worked for me, good luck.
    Tuesday, July 28, 2009 10:25 PM
  •  Here are the steps that you can try to resolve the issue.
    At first restart the spooler service from the services Window then follow these steps
    Open printers folder
    Right click on the printer icon and select properties.
     Click on Advanced tab.
    Select "print directly to printer" Click on Ok

    Then try printin!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    First I had to get the appropriate printer driver for my XP 64 system, then Rocker's advice worked like a charm!
    Wednesday, August 05, 2009 2:26 PM
  • Try this:

    Before starting, backup your registry (and system).  Don't bother trying to use the File --> Server Properties --> Driver --> Remove function; it won't work.  Instead, reboot the machine into SAFE mode.

    1) Go to C:\Windows\System32\spool\drivers\x64\ --> Delete All the files

    2) Go to C:\Windows\System32\spool\drivers\W32X86\ --> Delete All the files

    3) Optional (really for x86 systems), Go to C:\Windows\System32\spool\PRINTERS --> Delete All the files

    4) This step involves the Registry --> Back up the registry and/or the keys you delete should you need them!!

    5) Open Regedit

    6) Go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

    7) Delete ALL the sub keys

    8) Go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers

    9) Delete ALL the sub keys

    10) Go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Print Processors --> Delete ALL the sub keys

    11) Close Registry Reboot

    12) Go to "Turn Windows features on or off" in the control panel

    13) Uncheck "Windows Fax and Scan"

    14) Reboot

    15) Go to "Turn Windows features on or off" in the control panel

    16) Recheck "Windows Fax and Scan"

    17) Reboot

    At this point you should have a stable print spooler. 

    Monday, August 10, 2009 11:41 AM
  • Hi

    I have just bought a Dell laptop running vista 64, I got the thunking spooler error with 2 hours of using my printers.

    Installed an HP 1010 with 64 bit driver and an Espon 915 with what Ii understood was a 64 bit driver.

    Unable to remove fault, tried following your steps but did not have an option to turn off and then on the fax and scan, it was not in windows features. How do i get this started?

    When i restarted the machine, the spooler had an error and failed to restart, got an error 1053 i think

    As the machine is so new I have now completed a factory restore, will this have removed the fault?

    Only way i can se to test this is to try printing again, which will mean installing printer agsin, if i get the fault again i will not know whether it is a new error or the unremoved original.

    Can anyone help me, dell did not have a clue?
    Thursday, October 15, 2009 6:29 PM
  • try this....

    open regedit

    Start->run->type"regedit">hit enter

    take a backup

    follow the path

    hkey_local_machine>system>currentControlSet>services>highlight "spooler"

    on the right hand pane, have the following values ONLY delete every other entry.

    Name                                       Data

    (Default)                                  (value not set)

    Depend on Service                    RPCSS

    Description                               Loads file into memory for later printing

    Display Name                           Print Spooler

    Error Control                            0x00000001 (1)

    FailureActions                           leave it the way it is (too long to explain :P)

    Group                                      SpoolerGroup

    Image Path                              %SystemRoot%\system32\spoolsv.exe

    ObjectName                             LocalSystem

    Start                                       0x00000002 (2)

    Type                                       0x00000110 (272)

    change the values to these settings if they are different.

    and remeber THESE settings ONLY.

    Hope this Helps, because i would hardly come to this forum. :P

    Tuesday, June 15, 2010 8:48 PM
  • I see here that seems that everyone is having print issues. I am having Excel issues. My computer is a Dell Corei7 with 8GB Ram running  Vista64

    I can open up some excel files and when I try to edit them every little simple mode like changing the font size will cause my computer to run very slow. I see in the task manager that splWOW64.exe jups up to the top in terms of cpu processes. After the change is finally made or updated the splWOW64 jumps down. Until I make my next edit. It is unbelieveable how discouraged I get knowing that my computer is a beast but acts like as slow a a 386!

    I can't imagine that my issue is printer related since I'm not printing anything. What is the purpose of this darn .exe


    • Proposed as answer by Syberchick Saturday, May 14, 2011 3:09 AM
    • Unproposed as answer by Syberchick Saturday, May 14, 2011 3:09 AM
    Tuesday, October 05, 2010 6:01 PM
  • Solved issue for Windows 7 64bit.

    Go to 'Devices and Printers'

    Right-click PDF printer, select 'Printer Properties'

    Go to 'Ports' tab, select the port 'FILE: Print to File'

    Apply, then print.

    I did get an error after this, but on closing the error, saw a 'file save' dialog for a pdf. I saved the file and voila - it worked.


    Saturday, May 14, 2011 3:12 AM