locked
How to change the strange "Tab" behavior RRS feed

  • Question

  • User-1890023382 posted

    I installed a new visual studio 2015 on my computer.But found that the "tab" key behavior become very strange:

    1.I type public string Name following a "{" then vs will complete the "}" automatically.Then I type"get;set;" in the "{}" then want to type the "tab"key to get out of the "{}" and come to the end of the line.But when i enter the tab key,it select the next line!!!

    How can i change this behavior?

    Thursday, October 27, 2016 3:03 AM

Answers

All replies

  • User-2057865890 posted

    Hi Tyler,

    Go to Tools/Options/Text Editor/"language of choice"/Tabs and selecting smart indenting

    reference: https://msdn.microsoft.com/en-us/library/7sffa753.aspx 

    Best Regards,

    Chris

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, October 28, 2016 3:16 AM
  • User-1890023382 posted

    Thank you for your kind reply.It is calused by resharper! In resharper's options window,click the "editor behavior" and then uncheck "use tab/shift tab keys for structural for navigation,then visual studio's behavior come back to normal

    Friday, October 28, 2016 8:56 AM