none
Is there an Option for this in VS2015

    Question

  •  Hi all,

     I recently upgraded from VS2010 to VS2015 and have found some annoying things,  most of which i have found settings in the Options to change the behavior of.  However,  there is one that annoys the heck out of me and i can`t find a setting to change it.

     In VS2010 or VS2008 when you are currently typing a line of code,  the IDE did not show any errors on the current line until you pressed enter at the end of the line OR you moved the caret to another line.  Then it would highlight the error in the line of code if there was one.

     However,  in VS2015 it seems to highlight the WHOLE code as soon as it notices an error in the current line before you finish typing the line of code.  For example,  in the image below i type the beginning Quote as i am adding a String in the code.  The whole code is immediately shown as an error until i finish typing the string and type the ending Quote.

     Is there a setting to stop the IDE from checking the current line for errors until i am done typing that line or i move the caret to another line?  I can`t seem to find one if there is one.


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 8:32 PM

Answers

  • Hi IronRazera,

    I find this problem occurs in VB editor and it works fine in C# editor. I also compare the settings for VB and C# Text Editor, there are different and I don't find such settings for VB Text Editor. I'm afraid that this is a default action for VB Text Editor.

    I suggest you submit this problem to Visual Studio User Voice and you also can add comments under the feedback link that Mr. Monkeyboy provided in the first reply.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by IronRazerz Saturday, April 30, 2016 6:56 PM
    Thursday, April 28, 2016 2:17 AM
    Moderator

All replies

  • In older VS that's supposedly called "live semantic errors" which someone requested the ability to alter in VS2015 here Option to show live semantic errors only upon statement completion but maybe this thread can help How to disable real time compilation in Visual Studio 2015 although I'm still looking.

    La vida loca

    • Edited by Mr. Monkeyboy Sunday, April 24, 2016 9:32 PM Changed "turn off" to "alter"
    Sunday, April 24, 2016 9:06 PM
  • Apparently you can alter the registry to change the behaviour, at least for VS2015 preview. Also the registry info is probably wrong below since Visual Studio release may not be 14.0 (preview) but 15.0 or something.

    blog.lebosquain.com

    "In previous versions of Visual Studio, it was possible to disable live semantic errors in options. Not in VS2015 Preview.
    Luckily, you can still fiddle with the registry!

    • Create the key HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0\Roslyn\Internal\OnOff\Features
    • Add a new value named Squiggles of type DWORD, and give it a value of 0.
    • Restart Visual Studio."


    La vida loca

    Sunday, April 24, 2016 9:13 PM
  • Mine doesn't do that.  As soon as I enter the first " it immediately adds the closing ".

    If I delete the closing " then I see what you are getting.

    I remember changing lots of things when I first tried it so I'll try and remember what I did.  In the end I gave up on it as it was way too slow and went back to VB 2010.

    Sunday, April 24, 2016 9:13 PM
  •  Thanks John,  i will look at the links that you provided and see if it works.  I did not know the name of that setting in VS2010 because it must be turned off by default in 2010 and i never had to figure it out until now.  8)


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 9:18 PM
  • Well the registry change may not be accurate since Visual Studio 2015 may be 15.0 rather than 14.0 which the preview version was. You're welcome.

    La vida loca

    Sunday, April 24, 2016 9:24 PM
  • Mine doesn't do that.  As soon as I enter the first " it immediately adds the closing ".

    If I delete the closing " then I see what you are getting.

    I remember changing lots of things when I first tried it so I'll try and remember what I did.  In the end I gave up on it as it was way too slow and went back to VB 2010.

     Hey Dave,

     Yes,  mine added the second quote automatically by default but,  that was one of the things that i did not like.  I turned that off by changing the "Automatic Brace Completion" setting.  I guess if the links that John posted don`t work for me,  i will just turn it back on.


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 9:24 PM
  • So it's your own fault then :-)

    I was just about to post to tell you about that but no need now.

    Be interested to know how you find it with regard to speed.  I have to admit that having just tried it again it wasn't as bad as last time I used it - it's only a slight exaggeration to say that I could make a coffee while it loaded and drink most of it while it created a new project.

    Sunday, April 24, 2016 9:33 PM
  • Well I'm still looking. I don't know how this would affect info in the Code Window though and it was for C++ but I suppose VB would have the same feature. I will only update this post if I find anything new also.

    From link option to disable quick action squiggles although green squiggles are mentioned so I don't know if Visual Studio or Resharper that people mention in the thread is being referred to.

    "Tom  commented  ·  January 22, 2016 07:53

    OK, you can hide the green squiggles:

    Go to: Tools -> Options -> Environment -> Fonts and Colors 
    Find the entry: C++ Suggested Action
    Set: Item Foreground to White (or whatever your window background color is)

    Of course the squiggles are still there, so you'll still get popups when you mouse over the affected lines, but at least you won't see them!"

    Update: Something about rulesets which is maybe not a user setting but set for each app perhaps. And info at link is about C++ but probably VB uses them too. Also Squiggles are apparently the Light Bulb or something. Maybe finding out how to turn off the light buld?

    How do you disable the light bulb in Visual Studio 2015?

    Update 2: How to disable “Light Bulb” Quick Action “simplification” for Nullable<t>?</t>


    La vida loca

    Sunday, April 24, 2016 9:40 PM
  •  @ Dave,

     LOL,  yes it is my own fault in a way.  I just hate the IDE trying to tell me everything or correct my code before i am even done typing the line.

     What do you mean about the Speed?  Do you mean the speed of VS2015 in general?


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 9:46 PM
  •  John,

     I checked out those links but,  the first one shows an option in the Advanced node which does not seem to be listed in the Advanced node of the options.  Not sure why though.

     The second link,  i tried to give a 3+ vote to the suggestion and it would not let me.  It would not let me even leave a comment.

     The third link from the second post seems to be messed up or something,  it gave me the 404 not found error.

     At least i know what the name of the setting is now anyways.   8)


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 9:52 PM
  • Try this link. I copied the shortcut from the title of that blog post at the top and I guess the shortcut is invalid that the title, if selected, should take you to.

    http://blog.lebosquain.net/

    Update: That link let me add 3 votes after I entered an email address. Also let me know if anything works and I'll post a discussion in the Visual Studio General Questions and Visual Studio Editor forums I suppose. And I downloaded/tested VS 2015 Preview a long time ago and it was extremely slow and sluggish on my PC which maybe is what Dave299 means.


    La vida loca

    Sunday, April 24, 2016 9:54 PM
  • So it's your own fault then :-)

    I was just about to post to tell you about that but no need now.

    Be interested to know how you find it with regard to speed.  I have to admit that having just tried it again it wasn't as bad as last time I used it - it's only a slight exaggeration to say that I could make a coffee while it loaded and drink most of it while it created a new project.


    I have been using 2015 for several months (before that 2013). I had my no 1 program in 2010 until I got 2015 AND THEY ADDED AN MSI update for 2015 so you can make run the MSI install projects from 2010 in 2015 now. I am doing anything new in 2015 and converted most of my other painlessly. My large 2010 project updated to 2015 with no problems as does everything 2010 and up. I dont have any 2008.

    I have never noticed much difference in any of them 2010 up other than the cosmetics and some of the smarter IDE corrections. Speed I never noticed a difference, not that there isnt one. I still use them all for various things. I only use the basic things so nothing fancy other than DirectX.


    PS There are some nice new tools and things in 2015 but I cant think of them specifically you just notice them here and there.
    Sunday, April 24, 2016 10:19 PM
  • Try this link. I copied the shortcut from the title of that blog post at the top and I guess the shortcut is invalid that the title, if selected, should take you to.

    http://blog.lebosquain.net/

    Update: That link let me add 3 votes after I entered an email address.


    La vida loca

     Well,  after skimming through the links in your last two posts,  i am starting to think that there is just not a way to stop the error checking on just the current line in the options.  I do remember now that,  there was an update for VS2015 that i chose to dismiss right after i installed VS2015 so,  maybe i need to get those updates and see if they add any of those options i seem to be missing.   If the update does not help,  i think i will just have to deal with it.

     Strange,  i added my email at that link and it told me it could not process my vote at the time.  I tried 3 or 4 times to vote and got the same error.  I will have to try again though.

     Thanks for all the effort you have put into searching for an answer,  i really do appreciate it.   8)


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 10:32 PM
  • I have never noticed much difference in any of them 2010 up other than the cosmetics and some of the smarter IDE corrections. Speed I never noticed a difference, not that there isnt one. I still use them all for various things. I only use the basic things so nothing fancy other than DirectX.

      There`s Triple T,

     I noticed on my machine that starting up VS2015 seems to take a little longer than VS2010 does.  As far as loading a project,  it seems to be about the same speed as 2010.   As i already mentioned to you the other day,  i don`t care for the look of 2015 (the plain jane metro look) but,  that is just my opinion.  Other than the slight speed hit in the original startup of 2015 and a few odd-n-end little things like the subject of this question,  i guess i like 2015 pretty good so far.


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 10:46 PM
  • I have never noticed much difference in any of them 2010 up other than the cosmetics and some of the smarter IDE corrections. Speed I never noticed a difference, not that there isnt one. I still use them all for various things. I only use the basic things so nothing fancy other than DirectX.

      There`s Triple T,

     I noticed on my machine that starting up VS2015 seems to take a little longer than VS2010 does.  As far as loading a project,  it seems to be about the same speed as 2010.   As i already mentioned to you the other day,  i don`t care for the look of 2015 (the plain jane metro look) but,  that is just my opinion.  Other than the slight speed hit in the original startup of 2015 and a few odd-n-end little things like the subject of this question,  i guess i like 2015 pretty good so far.


    If you say it can`t be done then i`ll try it

    What machine are you running it on? I have :


    La vida loca

    Sunday, April 24, 2016 10:49 PM
  •  I am on an older Dell Inspiron laptop,


    If you say it can`t be done then i`ll try it

    Sunday, April 24, 2016 10:58 PM
  •  I am on an older Dell Inspiron laptop,


    If you say it can`t be done then i`ll try it


    Well maybe the issue was VS 2015 Preview was Ultimate. Maybe I'll download Community and give that a try. Tks!

    La vida loca

    Monday, April 25, 2016 12:32 AM
  • I think it may be worth trying again.  VS2015 seems to be a lot faster than last time I tried it

    It's still a lot slower than VB2010 but then it does a lot more so maybe that is to be expected.

    My system looks like this:

    and for VB2010, after a reboot, first run takes about 8 seconds and another 5 seconds to create a new project.

    VB2015 takes about 20 seconds on first run, another 20 seconds to display a dialogue for choosing a project type and then another 20 seconds to create the project.  And that's a huge improvement on what it used to be!!

    Monday, April 25, 2016 12:55 AM
  • Here is mine.

    Monday, April 25, 2016 1:44 AM
  • Here is mine.


    Do you have VS2015 Enterprise, Pro or Community?

    La vida loca

    Monday, April 25, 2016 2:19 AM

  • Do you have VS2015 Enterprise, Pro or Community?

    La vida loca


    Community.
    Monday, April 25, 2016 2:48 AM
  • I think it may be worth trying again.  VS2015 seems to be a lot faster than last time I tried it

    It's still a lot slower than VB2010 but then it does a lot more so maybe that is to be expected.

    My system looks like this:

    and for VB2010, after a reboot, first run takes about 8 seconds and another 5 seconds to create a new project.

    VB2015 takes about 20 seconds on first run, another 20 seconds to display a dialogue for choosing a project type and then another 20 seconds to create the project.  And that's a huge improvement on what it used to be!!


    I know that would be much faster than the VS 2015 Preview I tested back when.

    La vida loca

    Monday, April 25, 2016 2:55 AM
  • VS 2015 Desktop Express version with Update 2 starts up much faster then the initial release did, 

    Hmmm, I don't see those goofy squiggly lines with update 2 now, only the actual error has the red lines now.

    Win7 Home, i7-3700 @ 4GHz, 16GB Ram, cheap Mushkin SSD drive.

    Not sure if this will work, animated gif,..

    http://i.imgur.com/eQ5Odhb.gifv

    EDIT

    2nd Run - Now that its cached in ram, takes about 4 secs.

    http://i.imgur.com/dOf217u.gifv


    • Edited by Edgemeal Monday, April 25, 2016 4:09 AM THIS FORUM SOFTWARE SUCKS!
    Monday, April 25, 2016 3:54 AM
  • Hey Edgemeal,

     Have not seen you around in a while.  I have VS2015 Community and i believe it was Update 2 that i chose to Dismiss right after i installed 2015.  So,  i will try to get Update 2 later and see if that fixes my problem.  Thanks.    8)


    If you say it can`t be done then i`ll try it

    Monday, April 25, 2016 10:29 AM
  • Hi IronRazerz,

    Do you have resolved your problem now?

    If resolved, please share your solution here and then mark the helpful reply as answer which is benefit to other communities who has the same problem.

    If not, please tell us what's the result now. We are waiting for your response. Thanks.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, April 27, 2016 6:55 AM
    Moderator
  • @ Weiwei Cai,

     Well,  after my other question was answered on here yesterday about getting Update2,  i got the Update installed with no problems.  However,  it did not fix the original problem of this thread.  I guess there is not an option to turn the error checking off for the current line that i am typing.

     So, from what i found so far,  i will either have to deal with it OR turn the "Automatic Brace Completion" back on.  If you have any suggestions then i would be glad to here them as long as it does not involve turning the error checking off completely.   8)


    If you say it can`t be done then i`ll try it

    Wednesday, April 27, 2016 9:43 AM
  • Hi IronRazera,

    I find this problem occurs in VB editor and it works fine in C# editor. I also compare the settings for VB and C# Text Editor, there are different and I don't find such settings for VB Text Editor. I'm afraid that this is a default action for VB Text Editor.

    I suggest you submit this problem to Visual Studio User Voice and you also can add comments under the feedback link that Mr. Monkeyboy provided in the first reply.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by IronRazerz Saturday, April 30, 2016 6:56 PM
    Thursday, April 28, 2016 2:17 AM
    Moderator
  •  Sorry for the late reply.  I did compare the settings between C# and VB and noticed that there where differences too.  Anyways,  thank you for the suggestion and link to report this.   8)

    If you say it can`t be done then i`ll try it

    Saturday, April 30, 2016 7:00 PM