Juniper SSL VPN on Windows 8 Consumer Preivew RRS feed

  • Question

  • Greetings all.. 

    i have been having some issues getting my company VPN to work properly on my Samsung Series 7 Slate running Win 8 Consumer Preview.  My company uses Junper's Network Connect for its VPN and every time i try to login, Network Connect attempts to connect to the VPN but eventually times out and i receive a "Connection attempt timed out.  (nc.windows.app.2370)" or "The Network Connect session terminated. Do you want to reconnect? (nc.windows.app.23712)"  error message. 

    Has anyone been able to successfully get their VPN working properly? Any information would be greatly appreciated. Thank you. 

    Monday, March 5, 2012 5:43 AM

All replies

  • No solution, unfortunately, though we are not alone.  Found another thread on MS Answers forum:


    Looking / testing, and keeping hope alive....

    Tuesday, March 6, 2012 12:51 PM
  • thats a shame.. i really hope MS or juniper come up with a fix
    Wednesday, March 7, 2012 2:59 AM
  • I read the replies @ http://answers.microsoft.com/en-us/windows/forum/windows_8-networking/juniper-network-connect-710-problems/8af96038-50c7-4494-b64f-a7267bb97d56?page=2&tab=AllReplies&auth=1 and then tried the last reply which states as mentioned below. It does work and I was able to use my Juniper VPN fine. This is something that Microsoft will need to look at and see why these services on Windows 8 does not allow Juniper VPN to work.

    The workaround:

    From an administrator cmd shell:
    net stop bfe

    You may need to go into Services and manually disable and stop

    • Windows Firewall
    • IKE and Auth IPSec Keying Modules

    for the Base Filtering Engine to shut down.

    Obviously this is something you should just quickly test as this will leave your machine vulnerable to bad stuff :-)

    Make sure these services are running after you're done testing (and any other service that might have been stopped by the "net stop bfe" command):

    • Base Filtering Engine
    • IPSec Policy Agent
    • Windows Firewall
    • IKE and Auth IPSec Keying Modules

    My cmd shell displayed the following and I plan to ensure that those services run after I disconnect from VPN:

    C:\Windows\system32>net stop bfe
    The following services are dependent on the Base Filtering Engine service.
    Stopping the Base Filtering Engine service will also stop these services.

       Windows Firewall
       IKE and AuthIP IPsec Keying Modules

    Do you want to continue this operation? (Y/N) [N]: y
    The Windows Firewall service is stopping.
    The Windows Firewall service was stopped successfully.

    The IKE and AuthIP IPsec Keying Modules service is stopping.
    The IKE and AuthIP IPsec Keying Modules service was stopped successfully.

    The Base Filtering Engine service is stopping.
    The Base Filtering Engine service was stopped successfully.


    • Edited by anupj Thursday, April 5, 2012 3:23 AM Added link which I missed to add
    • Proposed as answer by anupj Tuesday, July 31, 2012 5:12 PM
    Thursday, April 5, 2012 3:22 AM
  • Wanted to let everyone know that the problem has been fixed in Windows 8 RC. Just make sure to allow access to file:/// when prompted.
    • Proposed as answer by anupj Tuesday, July 31, 2012 5:12 PM
    Friday, June 1, 2012 3:01 AM
  • I have the same issue (we use Network Connect at work).  We also support the Pulse Client for other devices, and the Windows version of the Pulse client provides me access without issue.  It does mess up my networking though when installed - basically amounts to needing a network troubleshooter repair of some sort after each reboot, so I keep a copy of the install on my machine, and just install it when needed.


    Monday, June 4, 2012 6:31 PM
  • Don't know if anyone has updated this in a while, but Juniper Network Connect (at least version 6.5) is now working in Release Preview.  Not sure if a patch came out or it always worked with RP, but thought someone ought to update this thread.  So there it is!


    Wednesday, June 27, 2012 2:40 AM
  • Wanted to let everyone know that the problem has been fixed in Windows 8 RC. Just make sure to allow access to file:/// when prompted.

    I have confirmed that what Protis mentioned is correct, the issue has been fixed in Windows 8 RC. Just to add.....there was no prompt, it just worked directly.


    • Proposed as answer by anupj Tuesday, July 31, 2012 5:16 PM
    Tuesday, July 31, 2012 5:16 PM
  • Followed the instructions at the page below to rename the dsncadpt.sys and restart, then reinstall.. Can now connect, though the web page hangs at the Connecting status, the 6.5 client connects.


    Here's the helpful info


    I ran across this error also during a reinstall.  I was able to resolve the issue by doing this:

    1) From control panel, uninstall all Juniper products
    2) From %systemroot%\system32\drivers, rename dsNcAdpt.sys to dsNcAdpt_old.sys (I'm sure deleting would work too)
    3) Reboot (IMPORTANT!)
    4) Do the install again...it worked.

    Hope this helps somebody!

    • Edited by BobCGRR Wednesday, September 19, 2012 12:57 AM
    Wednesday, September 19, 2012 12:39 AM
  • Go to Windows Firewall with Advanced Security options

    Create a new connection security rule, select tunnel, client-to-gateway, do not authenticate (you will use your corporate token or method to handle this) .

    What  are the remote endpoints option select add, add the ip address or  subnet block of the ssl vpn gateway.

    You can get this through DNS lookup or your IT department. Click Next, and set a custom name to the profile like work vpn, etc.

    Once set, you can vpn correctly to the company network. I tested this with Juniper 7.1 and I believe this should work with other versions as well. Note that this procedure only applies to Windows 8 with the default Windows Firewall package loaded (by default is turn on)

    • Proposed as answer by FirewallGuy Saturday, October 27, 2012 4:58 AM
    Saturday, October 27, 2012 4:57 AM
  • My workaround is from the Desktop use IE9.

    Saturday, October 27, 2012 9:15 AM