none
Backup suddenly failing with internal error RRS feed

  • Question

  • We have a backup vault with 18 azure vm's registered to it, to backup some folders on each machine every night. This has been running fine for months now, with the occasional update of the backup agent.

    Now, since yesterday night, the backup on 14 servers is failing with the message:
    Microsoft Azure Backup encountered an internal error. Wait for a few minutes and then try the operation again. If the issue persist, please contact Microsoft Support (0x1FBD1)

    What I've tried
    -a manual backup: this failes with the same error code
    - restarted one of the servers, and tried a manual backup; also failes
    - created a new backup vault, unregistered one of the servers and tried registering it to the new backup vault. This takes a very long time, more then usual when setting up the backup, and then failes trying to set the encryption keys.

    Last night all backups failed again, except for the same 4 that have succeeded.
    Does anyone have a tip what to do or what to look for?

    Wednesday, July 13, 2016 7:49 AM

All replies

  • Hi Jeroen,

    Thank you for posting here!

    Please check is backup agent has been updated to the latest version? If not please update the backup agent and check the status of the issue.

    Refer to  the below mentioned link for updating the Azure Backup agent.

    https://azure.microsoft.com/en-in/blog/mandatory-update-for-azure-backup-agent/

    If the issue still persist. I would request; You may open a support ticket with our technical team for much detailed analysis of the issue:
    http://azure.microsoft.com/en-us/support/options/

    Regards,
    Sumanth BM

    Wednesday, July 13, 2016 5:14 PM
    Moderator
  • Hi Sumanth,

    Yes, the agent is the latest version. I have a monitoring task for the backup, and it warns everytime an update is needed. 

    However, good news: for some reason, last night all backups are completed successfully.
    On one hand this is very nice, on the other, it doesn't give me a comfortable feeling on to why something suddenly stops working and after 2 days starts to work again without any changes on my side.


    Thursday, July 14, 2016 6:52 AM