none
symbol caching broke visual studio 2015

    Question

  • Hello,

    I seem to have inadvertantly broken Visual Studio 2015. I was looking for a way to stop it from constantly loading symbols every time I ran my application (since that seems to take forever). I came across a few sites on google that said to go to TOOLS > Options > Debugging > General > Check "Enable Just My Code" and also go to TOOLS > Options > Debugging > Symbols > set a directory for caching symbols and click "Load all symbols" to download them from the Microsoft server. So I did that but it seemed to hang while downloading the symbols from Microsoft, so I cancelled the operation.

    But now, there are certain breakpoints in my application that cause Visual Studio to crash. For example, there's a function call that returns data from a database stored procedure and then I do some linq operations on it (all as one line), and it crashes at this point complaining that it cannot find HttpApplication.cs (or sometimes ScriptModule.cs).

    It says:

    HttpApplication.cs not found

    You need to find HttpApplication.cs to view the source for the current call stack frame

    Try one of the following options:

    - Browse and find HttpApplication.cs...

    You can view disassembly in the Disassembly window. To always view disassembly for missing source files, change the setting in the Options dialog.

    Source search information:

    Locating source for 'f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs'. Checksum: SHA1 {cf 18 a5 24 f0 ac be 80 5c 3f 23 42 64 a1 10 9b ce 64 27 84}
    The file 'f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs' does not exist.
    Looking in script documents for 'f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs'...
    Looking in the projects for 'f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs'.
    The file was not found in a project.
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\cvt\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\msclr\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\sys\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\thr\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\amd64\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\arm\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\concrt\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\i386\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\linkopts\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\stl\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\vccorlib\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\crt\src\vcruntime\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\atlmfc\src\mfc\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\atlmfc\src\atl\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\atlmfc\include\'...
    The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs.
    The debugger could not locate the source file 'f:\dd\ndp\fx\src\xsp\system\Web\HttpApplication.cs'.

    I tried everything from recompiling my code to rebooting my computer.

    I also tried undoing my changes: I unchecked Enable Just My Code, but when it came to undoing the cached symbols directory, I forgot where the default/original directory does (so part of my question involves how to reset it back to its original settings).

    Other than that, I'm not sure to fix this problem. Does anybody know what I can do?

    Thanks.
    Thursday, October 27, 2016 6:30 PM

Answers

  • Hi gib898,

    Please reset your VS settings firstly.

    Please re-enable the Microsoft symbol server under TOOLS->Options->Debug->Symbol, and then re-debug it again. Maybe it would spend a few seconds to load the assembly during the first time debugging. Or you could run your VS as the admin to load the symbols.

    Please also disable the option "require the source file to exactly match the original version", and enable .net framework source stepping, uncheck Enable source server support, check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by gib898 Monday, November 7, 2016 11:11 PM
    Sunday, November 6, 2016 7:06 AM
    Moderator

All replies

  • Hi gib898,

    Thank you for posting here.

    Since your problem is more related to Visual Studio General Questions, I will move it to Visual Studio General Questions Forum for suitable support.

    The Visual C# forum discuss and ask questions about the C# programming language, IDE, libraries, samples, and tools.

    If you have some grammar or code errors, please feel free to contact us. We will try our best to give you a solution.

    Thanks for your understanding and cooperation.

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, October 28, 2016 2:13 AM
  • Hi gib898,

    Do you debug project/library which has no the source code?

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/933f62dd-80e5-4ef3-9199-9e9abfefeadf/no-source-available-the-source-cannot-be-displayed?forum=vsdebug

    Please check that whether your app is in debug mode, maybe it will impact the debugging result in release mode.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 1, 2016 7:48 AM
    Moderator
  • VS was in "Add Config Transform" mode. I switched to debug. I'm still getting that weird screen that says it can't find HttpApplication.cs every time it crashes.
    Thursday, November 3, 2016 2:43 PM
  • Hi gib898,

    Please reset your VS settings firstly.

    Please re-enable the Microsoft symbol server under TOOLS->Options->Debug->Symbol, and then re-debug it again. Maybe it would spend a few seconds to load the assembly during the first time debugging. Or you could run your VS as the admin to load the symbols.

    Please also disable the option "require the source file to exactly match the original version", and enable .net framework source stepping, uncheck Enable source server support, check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by gib898 Monday, November 7, 2016 11:11 PM
    Sunday, November 6, 2016 7:06 AM
    Moderator
  • Thanks Jack, I think that worked.
    Monday, November 7, 2016 11:11 PM