locked
Unable to run Coded UI project using mstest.exe RRS feed

  • Question

  • Hi All,

    I am trying to run a solution which has 4 projects out of which, start up project is a Coded UI test. I am getting few DLL reference related issues (Direct or indirect dll is not found, even though the required DLLs are present) While trying to run the test using mstest.exe. However it runs successfully, when debugged from VS2010 IDE.

    Awaiting your solution as this is a high priority to me.

    Thanks in advance,
    Raghu

    Thursday, August 4, 2011 1:51 PM

Answers

  • Please open the Coded UI test project's output folder, make sure all referenced dll files are there. If any of dll file is missing, please back to Visual Studio IDE, right-click the corresponding project (which generate the dll file), select Properties, on the Properties page, select Build ->change Output path to the Coded UI test project's output folder.


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by eryang Tuesday, August 16, 2011 3:25 AM
    Tuesday, August 9, 2011 3:04 AM

All replies

  • Please open the Coded UI test project's output folder, make sure all referenced dll files are there. If any of dll file is missing, please back to Visual Studio IDE, right-click the corresponding project (which generate the dll file), select Properties, on the Properties page, select Build ->change Output path to the Coded UI test project's output folder.


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by eryang Tuesday, August 16, 2011 3:25 AM
    Tuesday, August 9, 2011 3:04 AM
  • Hi Eric,

    Thanks for your reply. I am able to run the test without errors but now I am getting time out error.

    I tried updating the time out for the test in the "test settings" file to different values, but failed to execute completely. The execution stops after 30 mins everytime.

    I am running the code using mstest.exe command line.

     

    Please find the attachment for screenshot. Seems like the project uses some default test settings file. Please let me know how to overwrite the test settings.


     

    Thanks in advance,

    Raghu


    Tuesday, August 9, 2011 1:00 PM
  • MSTest usage is out of support range of VS Debugger forum, but you can try ask this question at Visual Studio Team System - Testing forum for better support.

     

    Please feel free to let us know if you have any concern.


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, August 10, 2011 3:14 AM
  • Thanks Eric

    --Raghu

    Thursday, August 11, 2011 6:59 AM