locked
Using VS 2015 iOS static library output RRS feed

  • Question

  • This might be a bug with the current preview of VS 2015 (Community RC). If so I would like to report it, otherwise I would like some assistance if possible.

    VS 2015 seems to support the creation of iOS static C++ libraries. I can in fact create such a project and get it to compile using VCRemote. My problem is that it does not seem as if though one can actually do anything with the output.

    The first reason is because as far as I can tell, the .a is never actually copied back to the Windows machine after compiling because I could not find it anywhere even when a build is successful. Without the .a file, I cannot do anything with it...

    The second reason is that one would expect to be able to instruct VS to reference the output of the C++ library in a Xamarin.iOS C# application (which VS 2015 supposedly has native/very good support for). This works for Xamarin.Android and VS 2015 Android C++ library projects and has always worked for Windows projects... Currently it complains about the output not being a DLL or an EXE when I try to add a reference.

    These appear like bugs to me, and like rather small ones two. Am I missing something here? Otherwise, if someone from MS is listening, could you please fix this, because it is making a feature with huge potential quite useless.

    Saturday, June 20, 2015 11:00 AM

Answers

  • Gerhman,

    It makes no sense to report bugs in a forum, nobody of Microsoft is handling that. 

    The website for bugs is

    http://connect.microsoft.com


    Success
    Cor

    • Marked as answer by Tina-Shi Monday, June 29, 2015 10:26 AM
    Saturday, June 20, 2015 4:26 PM

All replies

  • Gerhman,

    It makes no sense to report bugs in a forum, nobody of Microsoft is handling that. 

    The website for bugs is

    http://connect.microsoft.com


    Success
    Cor

    • Marked as answer by Tina-Shi Monday, June 29, 2015 10:26 AM
    Saturday, June 20, 2015 4:26 PM
  • Gerhman,

    It makes no sense to report bugs in a forum, nobody of Microsoft is handling that. 

    The website for bugs is

    http://connect.microsoft.com


    Success
    Cor


    Ok thanks, I didn't know about that site...
    Sunday, June 21, 2015 12:30 PM
  • Hi Gerhman,

    Thanks for your reply.

    Since this VS2015 Community RC is not still a released RTM version now and you have submitted this feedback to the connect. So I think that Microsoft engineers will evaluate seriously.

    Please you  post the link here which will be beneficial for other members with the similar issue.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 23, 2015 3:29 AM
  • I am having exactly the same problem.

    Did you get any extra info bug-wise ?

    Tuesday, November 15, 2016 3:04 PM