none
Silverlight x64 kann nicht installiert werden

    Question

  • Hallo zusammen,

    ich hoffe mal, daß ich mit keiner Frage nerve, die hier schon mal gestellt wurde ;-)  ...per Suchfunktion bin ich jedenfalls leider zu keiner Antwort auf mein Problem gestoßen.

    Also wie bereits aus dem Titel meiner Frage erkennbar, schaffe ich es einfach nicht, die 64Bit-Version von Silverlight (aktuelle Version)  auf meinem Vista 64-Bit-System zu installieren.

    Mein System im Einzelnen: Windows Vista Home Premium 64-Bit (Service Pack 2) / RAM: 6,00 GB / Prozessor: Core2Duo P9700 @ 2,80 GHz / Festplatte: Samsung SSD

    ...die (technischen) Voraussetzungen sollten also alle Mal gegeben sein.

    Die Installation wird mit folgender Meldung abgebrochen: "Silverlight kann nicht installiert werden. Die 64.Bit-Verion von Silverlight wird vom Betriebssystem nicht unterstützt." (Meldungs-ID: 1518)

    Habe ein paar englische Beiträge zu diesem Problem von Ende 2011/Anfang 2012 gelesen - bin daraus aber nicht wirklich schlau geworden.           

    Zuvor hatte ich Silverlight 5 in der 32-Bit-Variante genutzt. Dessen Installation bereitete damals keine Probleme und ich nutzte diese Silverlight-Version mit dem aktuellen Firefox-Browser (ebenfalls 32-Bit). Jetzt möchte ich jedoch einen 64-Bit-InternetBrowser nutzen und strebe daher halt auch die 64-Bit Silverlight-Variante an. Mal ganz davon abgesehen, daß mir der Download bei Microsoft ja eben auch genau diese 64-Bit-Variante automatisch anbietet.

    Vor dem Installationsversuch von Silverlight x64 deinstallierte ich Silverlight 32-Bit und verwendete einen "(Registry-)Cleaner", um mich  ggf. vorhandener (Silverlight-)Überbleibsel zu entledigen.

    Mit dieser im englischen Forum erwähnten "Silverlight 5 Developer Runtime 64-Bit" probierte ich´s übrigens auch schon.  Klappte auch nicht zu installieren.

    Kann mir da jetzt also vielleicht noch jemand weiterhelfen? Bedanke mich im Voraus! :-)

    Freundliche Grüße

    Christian

    Tuesday, September 18, 2012 11:14 PM

Answers

All replies

  • Hallo Christian,

    schau mal hier:

      http://www.microsoft.com/getsilverlight/Get-Started/Install/Default.aspx (System Requirements)

    Da siehst Du dann auch, dass selbst Windows 7 ohne SP 1 derzeit nicht für Silverlight x64 geeignet ist.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Wednesday, September 19, 2012 6:52 AM
  • Hallo Stefan,

    wer (vernünftig) lesen kann, ist klar im Vorteil. ...und meine Wenigkeit konnte vermutlich nicht vernünftig lesen. ;-)

    Hatte die von dir verlinkte Seite natürlich vorher auch schon in Augenschein genommen. Aber hab natürlich vollkommen über diese "Sterne" (Fußnote) hinter den  Häkchen hinweggeschaut, die letztendlich überhaupt erst die 64-Bit-Fähigkeit für ein System signalisieren. Die Fußnote ist mir quasi erst jetzt durch deine Antwort ins Auge gestochen.

    Mein Fehler. Aber ich bedanke mich bei dir für die nette Antwort, die selbst mir blindes Huhn noch die (Silverlight-)Augen geöffnet hat. ;-)

    Freundliche Grüße

    Christian

    Wednesday, September 19, 2012 10:26 PM
  • Hallo,

    hat sich nach 2 Jahren denn nichts geändert ?

    Ich kann auch kein Silverligth installieren (Vista HP SP2) ...die x64 lässt sich nicht installieren wie oben beschrieben, und 'ne andere bekomme ich ja nicht installiert.

    Heisst das: ausgeträumt Silverligth ?

    Verstehe auch die Downloadautomatik nicht: warum wird mir die x64-Version angeboten wenn sie nicht läuft ?

    Gruss

    Franz


    Be a good forum member - mark posts that contain the answers to your questions or those that are helpful

    Saturday, December 20, 2014 10:06 PM
  • Das mit dem Downloadsystem wird wohl daran liegen, dass die Webseite nicht GENAU wissen kann, wie dein Computer ist. Stichwort "UserAgent". Dieser gibt die Version an, aber sonst nicht viel mehr. Hier ein Beispiel:

    Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0

    Also nimm es nicht übel. Und die 32-Bit Version ist auch gut ;)


    © 2015 Thomas Roskop

    Monday, December 22, 2014 2:40 PM