locked
Put a MessageBox warning issue RRS feed

  • Question

  • Hello,

    I have an extension which translates a single line inside the editor. You have to select the line an type a combination of keys to launch the translation (ctrl+shift+t). I am using the google ajax service to autodetect the current language. If the language that returns the service is not my current language I show a message box to warn the user that the translation could not be correct. Here is the problem, when I click or press enter to close the message, the editor window shows me a 't' after the text.

    I solved this when I press the enter key with a key processor overrriding the keyup event. I suppose that I have to do the same thing with the mouse click to solve the problem if the user clicks the mouse.

    So, my question. Is there any way to solve this?

    Regards.

    Tuesday, September 21, 2010 11:59 AM

Answers

  • Hi Amartinez,

     

    Thanks for your post.

    From your description, I suspect the extra 't' is typed when you trigger the shortcut key (ctrl+shift+t).

    And I'm not that clear about what did you do by overriding the keyup event.

    Could you please show me some code about shortcut key binding and the keyup event?

    By the way, you can bind the shortcut key in "Tools->Options->Environment->Keyboard".

    Looking forward to your reply.

     

    Best Regards,

    Ziwei Chen

    • Proposed as answer by Victor_Chen Monday, September 27, 2010 3:46 AM
    • Marked as answer by Victor_Chen Friday, October 15, 2010 2:04 AM
    Thursday, September 23, 2010 9:56 AM