locked
Workflows do not automatically start on WSS 3.0 SP2 RRS feed

  • Question

  • We run WSS 3.0 and have recently applied Service Pack 2. 

    I have built a document library which is setup to receive incoming emails.  In theory, we would like for a workflow developed thru SP Designer to automatically begin when a new email is received into this document library.  It's a very simple workflow that does nothing but generate an email to an email address external of our company.  You can manually start the workflow, but we must have it automatically generated or this process is not of any value to us.

    From everything that I've read, this issue was supposed to be fixed by SP2 being applied. 

    Has anyone applied SP2 and still experienced this issue?  If so, have you found a workaround?
    Thursday, January 7, 2010 4:29 PM

Answers

  • Just to give an update for anyone having this same issue...

    Running: stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true did resolve our issue.

    Friday, January 22, 2010 6:41 PM

All replies

  • Hi,

    Please make sure that the account associated with the workflow to another account that is not SHAREPOINT\SYSTEM. And also run the following command to enable auto-start on declarative workflows: stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true.

    For more information, please refer to blog: http://blogs.technet.com/victorbutuza/archive/2009/03/14/workflows-do-not-start.aspx

    Hope it helps.


    Xue-Mei Chang
    Monday, January 11, 2010 8:55 AM
    Moderator
  • Just to give an update for anyone having this same issue...

    Running: stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true did resolve our issue.

    Friday, January 22, 2010 6:41 PM