SQL2005Express Login error RRS feed

  • Question

  • Platform: XP embedded SP3

    I installed SQL 2005 Express Advanced Services SP3 using Windows authentication for the server and 'NT AUTHORITY\SYSTEM' as the account.  Installation succeeds with no errors, and I attach to an application-specific database successfully.

    However, when I reboot and my application tries to access the server it throws the following errors:

    Connection failed: SQLState: 08004
    SQL Server Error: 4060
    Server rejected the connection; Access to selected database has been denied.

    Connection failed: SQLState: 28000
    SQL Server Error: 18456
    [Microsoft][SQL Native Client][SQL Server] Login failed for user 'NT AUTHORITY\SYSTEM'.

    I guess my question is: how is it possible not to authenticate the SYSTEM account?  What do I need to do to fix this?

    Thanks for your help.


    Thursday, February 25, 2010 4:27 PM

All replies

  • Hi ,

    I think you might be using windows authentication in your applications connection string and is the application running on the same server as SQL server ?

    4060 error is login failed due to inability to open the default database for the login . Just add the login system account and set master as its default db.

    Thanks, Leks
    Thursday, February 25, 2010 6:46 PM
  • Hi,

    Please check the connection string, make sure you are using the correct protocol, authentication mode and user account.
    Chunsong Feng
    Microsoft Online Community Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, March 1, 2010 9:42 AM
  • Hi,

    Have you got any progress?
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Sunday, March 7, 2010 10:52 AM
  • I think it turned out to be a flaw in the ATTACH connection string, but no error was thrown so I thought it was working.

    I still get it periodically, but when I click "OK" on the logon failure popup it seems to then work correctly.  Could this be timing?  What if two applications tried to log in at the same time using the same credentials?  Since this only seems to happen immediately after bootup, could there be an issue with attempting logon when the server is not completely initialized, or not yet attached to the DB?

    I still don't see how the NT AUTHORITY\SYSTEM account could ever fail.


    Wednesday, March 10, 2010 6:29 PM