none
User having problem exporting query to Excel RRS feed

  • Question

  • Only one user is having this problem. It works fine for all other users.

    User right-clicks on a query and chooses Export -- Excel, then checks 'export with formatting'.

    They then get this message:

    There is a Format statement in a query called by the exported query:

    SELECT T.*, C.FN AS Firstname, C.LN AS LastName, C.Title AS UTitle, C.Org AS CompanyName, C.Division, C.Location, Format(C.Phone,'(@@@) @@@-@@@@') AS PubPhoneNumber, C.Ext, C.AltPhone AS AltTelNo, C.Fax AS FaxTelNo, C.Email AS EmailAddr01, C.MD, C.ClientType, C.ActiveSW
    FROM tblCSTickets AS T LEFT JOIN tblClient AS C ON T.ClientID = C.ID;

    Wednesday, November 23, 2016 8:54 PM

Answers

  • Thanks for the suggestion.

    Since everyone else's front-end was working ok, I just replaced that user's copy with one of the other copies.

    Why that one did not work will have to remain another MS Access  mystery.

    Wednesday, November 23, 2016 9:41 PM

All replies

  • Don't know if this is connected but when I open the users copy of the front end and do a compile, I get this error for an Excel Library. It's looking for 15.0 and the only one in the list is version 14.0:

    Wednesday, November 23, 2016 9:05 PM
  • Hi "AllTheGood..."

    The way you describe it you have distributed copies of the databas?

    My experience is that queries can become corrupt That explain why one user have problem, others not.

    I would open that query on the machine with problem and delete the part of the query containing "Format".

    Then save the query, then add the line with "Format" again.


    Best // Peter Forss Stockholm and Sigtuna GMT +1.00


    Wednesday, November 23, 2016 9:06 PM
  • Thanks for the suggestion.

    Since everyone else's front-end was working ok, I just replaced that user's copy with one of the other copies.

    Why that one did not work will have to remain another MS Access  mystery.

    Wednesday, November 23, 2016 9:41 PM