locked
accessing report server problems in vb.net web form application RRS feed

  • Question

  • User-1997257017 posted

    I think my problem is related to the web.config file not pointing to all the report server values correctly.

    Here is my problem

    When I execute an ssrs 2012 report in visual studio for a vb.net 2010 web form app that is embedded in the web app in a report viewer control on my workstation and on a test report server, the parameter value is loaded correctly for the report. When I run the stored procedure in sql server management studio pointing to the prod databases that loads the values to the parameters in the ssrs reports, the sql runs fine. 

    When I run the ssrs 2012 report on the production report server pointing to the production database, the parameter dropdownlist is sometimes populated and other times it is not populated. When I run the ssrs 2012 report with the same parameters, I can tell consistently when the parameter dropdown list will have values and when it will not have values.

    Thus can you tell me what I need to look at on the production report server, to see why the parameter value is populated in some cases and not in other cases?

    In addition, can you tell me and/or point me to a reference that I can use to see what the report server config file values should be in the config file? Something that will explain what the config file values should be.

    Friday, August 28, 2015 5:14 PM

Answers

  • User1644755831 posted

    Hello wendy,

    First of all I would suggests that you check IIS logs + put Trace logs in your code to see exactly what's going on.

    Please see: Troubleshooting (SSRS)

    As for the basic configuration on the SSRS report please see: Create a Basic Table Report (SSRS Tutorial)

    If you can narrow down the problem using IIS logs or the troubleshoot article then community members would be able to help you more.

    With Regards,

    Krunal Parekh

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 31, 2015 3:08 AM