none
Outlook 2010 (32bit) Windows 8 (64bit) Visual Studio 2010 - VSTO4 - Outlook Add-In Not Getting Loaded RRS feed

  • Question

  • Hi

    I am trying to build a Outlook 2010 Managed Add-In Using Visual Studio 2010 and VSTO40 on a Windows 8 64bit Machine.

    When i run the Add-in Project from Visual Studio, Outlook is getting launched, but my add-in never gets loaded. It is inactive state. 

    System Details

    Windows 8 64bit

    Visual Studio 2010

    .NET Framework 4.0

    VSTO40

    Microsoft Office Outlook 2010 (32bit)


    Thursday, September 11, 2014 2:48 PM

All replies

  • Most probably the exception is thrown at startup. Did you have a chance to check the Disabled Items list?

    Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in when you try to debug it, the application might have hard disabled or soft disabled your add-in.

    Hard disabling can occur when an add-in causes the application to close unexpectedly. It might also occur on your development computer if you stop the debugger while the Startup event handler in your add-in is executing.

    Soft disabling can occur when an add-in produces an error that does not cause the application to unexpectedly close. For example, an application might soft disable an add-in if it throws an unhandled exception while the Startup event handler is executing.

    When you re-enable a soft-disabled add-in, the application immediately attempts to load the add-in. If the problem that initially caused the application to soft disable the add-in has not been fixed, the application will soft disable the add-in again.

    You can read more about this in the How to: Re-enable an Add-in That Has Been Disabled article in MSDN.

    Thursday, September 11, 2014 2:55 PM
  • There can be a number of reasons your addin gets made inactive, for example missing dependencies. See http://blogs.msdn.com/b/vsod/archive/2012/10/08/troubleshooting-common-vsto-issues-part-2.aspx for information on troubleshooting VSTO addins.

    Ken Slovak MVP - Outlook

    Thursday, September 11, 2014 3:06 PM
    Moderator