locked
TF400324: Team Foundation services are not available from server RRS feed

  • Question

  • I only use Visual Studio (Community 2015) for source control services through TFS. The TFS server runs on the same local machine. After a recent Windows 10 (Home) update I started receiving the following error messages:

    TF205020: Could not connect to server ‘xxxx\yyyy'. This server was used in your last session, but it might be offline or unreachable. Confirm that the server is available on the network. To attempt to connect again, or to a different server, click ‘Connect To Team Foundation Server’ in Team Explorer or the Team menu.

    The server returned the following error: TF400324: Team Foundation services are not available from server office-pc\DefaultCollection.
    Technical information (for administrator):
      Unable to connect to the remote server

    I cannot access the TFS server through a web browser either. I've tried clearing caches as suggested in other posts but to no avail. Any suggestions to resolve this issue would be much appreciated.

    Monday, July 17, 2017 1:37 PM

Answers

  • Hi AFirmwareGuy,

    Thanks for posting here.

    Please  check if any services related TFS are not started. Can you open the Administration Console? Check if any exceptions there. If you are using trial version. just try to complete the trail, then try it again.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by AFirmwareGuy Tuesday, July 25, 2017 6:49 PM
    Tuesday, July 25, 2017 1:31 AM

All replies

  • Hi AFirmwareGuy,

    Thanks for posting here.

    Please try to clean the caches following below steps, then try it again:

    1. Close all instances of Visual Studio.
    2. Open the Task Manager and check if any TFS Services are running. Select each of them and click on End Process Tree.
    3. Browse to the folder below and delete all the contents and folders in %LocalAppData%\Microsoft\Team Foundation\{version}\Cache 
    4. Restart Visual Studio and try triggering build.
    5. If you are switching from one version of TFS to another, you may require repeating this solution again. If you are using older version of TFS, you may have to navigate to %LocalAppData%\Microsoft\Team Foundation\  and find out the version folder instead of navigating directly.

    See TF400324: Team Foundation Services are not available from server for more information.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, July 21, 2017 4:16 PM
  • Thanks for the reply.  As I mentioned in my original post, I already tried clearing caches but it didn't help.  I'm almost certain this error started occurring right after a major Windows 10 update.
    Monday, July 24, 2017 1:08 PM
  • Hi AFirmwareGuy,

    Thanks for posting here.

    Please  check if any services related TFS are not started. Can you open the Administration Console? Check if any exceptions there. If you are using trial version. just try to complete the trail, then try it again.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by AFirmwareGuy Tuesday, July 25, 2017 6:49 PM
    Tuesday, July 25, 2017 1:31 AM
  • That was it!  Somehow SQL server services became disabled at system startup.  As soon as I restarted SQL (and re-enabled automatic startup), everything worked fine.  Thanks Andy-Li!
    Tuesday, July 25, 2017 6:52 PM