none
failed to load device console RRS feed

  • Question

  • I get the error 'Failed to load device console' when I try to open the Device
    Console in DTM Studio. My system was working OK ans I have certified several
    drivers.

    The Job Monitor window works OK and I can add a new client to a pool and can
    run the MCU policy OK.

    All my old pools are visible in the Job Monitor window.

    I have re-installed DTM Studio and get the same error. I can see my
    controller OK.

    The error report information is 'Could not connect to the controlled to
    retrieve information.'. VoidConnectToNamedDataStore and GetCOntrollerInfo are
    the problem calls.

    Is there a setting somewhere that could have been corrupted?

    Complete error message is :

    Error messages include inner exceptions. Level 0 denotes the outermost exception.

    ------------------------------ Level 0 ------------------------------

    Message: Could not connect to the controller to retrieve information.  Several issues can cause this error including missing or corrupt files from the installation, running the studio application from a folder other than the install folder, and running an application that accesses the scripting APIs from a folder other than the installation folder.
    Source:DeviceScript
    Target site: Void ConnectToNamedDataStore(System.String)
    Stack trace:
       at Microsoft.DistributedAutomation.DeviceSelection.DeviceScript.ConnectToNamedDataStore(String dataStoreName)
       at Microsoft.DistributedAutomation.DeviceSelection.SelectionControl.InitialLoad()

    ------------------------------ Level 1 ------------------------------

    Message: Could not retrieve necessary information from the controller.
    Source:DeviceScript
    Target site: Void GetControllerInfo()
    Stack trace:
       at Microsoft.DistributedAutomation.DeviceSelection.DeviceScript.GetControllerInfo()
       at Microsoft.DistributedAutomation.DeviceSelection.DeviceScript.ConnectToNamedDataStore(String dataStoreName)

    Wednesday, December 26, 2012 2:06 PM

All replies

  • The usual causes for this issue are:

    • A client system is in the System pool. Move the client system out of system pool into the default pool.
    • Name/Domain changes on the system the DTM Controller is installed on (rename to original system/domain name).

    Hope that helps,

    Prakash

    Wednesday, December 26, 2012 10:58 PM
  • Hi prakash,

    I have tried these two solution but problem still persist.

    Can you suggest some more solution

    Thursday, December 27, 2012 8:18 AM
  • Can you try the following:

    1. Closing all instances of DTM Studio

    2. Delete the directory %userprofile%\AppData\Roaming\Microsoft\WTT

    3. try launching Device Console again.


    This posting is provided "AS IS" with no warranties, and confers no rights

    Tuesday, January 1, 2013 2:50 AM